AHCF-MIB
67 objects
The MIB module describes a object definition for history collection.
Imported Objects
| HOST-RESOURCES-MIB | -- RFC2579 InternationalDisplayString |
| RMON-MIB | -- RFC2790 OwnerString |
| SNMPv2-CONF | -- RFC2021 MODULE-COMPLIANCE NOTIFICATION-GROUP OBJECT-GROUP |
| SNMPv2-SMI | Gauge32 Integer32 mib-2 MODULE-IDENTITY NOTIFICATION-TYPE OBJECT-TYPE |
| SNMPv2-TC | -- RFC2578 RowStatus DisplayString TimeStamp |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.2.1.7777 | IdentityahcfMIB | The MIB module describes a object definition for history collection. | ||
| 1.3.6.1.2.1.7777.1 | NodeahcfObjects | |||
| 1.3.6.1.2.1.7777.1.1 | TableahcfConfigTable | not-accessible | current | A list of data-collection configuration entries. |
| 1.3.6.1.2.1.7777.1.1.1 | RowahcfConfigEntry | not-accessible | current | List of parameters that set up sampling on a user specified MIB variable(a scalar variable or a columnar variable). |
| 1.3.6.1.2.1.7777.1.1.1.1 | ColumnahcfConfigIndex | not-accessible | current | An index that uniquely identifies an entry in the ahcfConfigTable. |
| 1.3.6.1.2.1.7777.1.1.1.2 | ColumnahcfConfigObjectVariable | read-create | current | The object identifier of the particular MIB variable to be sampled. Only variables that resolve to an ASN.1 primitive type of Integer32 (Integer32, Counter, Ga… |
| 1.3.6.1.2.1.7777.1.1.1.3 | ColumnahcfConfigObjectType | read-create | current | The type of the object variable specified in ahcfConfigObjectVariable. If this object is set to 'scalar', then ahcfConfigObjectVariable will contain the comple… |
| 1.3.6.1.2.1.7777.1.1.1.4 | ColumnahcfConfigObjects | read-only | current | The number of rows in the ahcfInstanceTable associated with this ahcfConfigEntry. If ahcfConfigObjectType is 'scalar', then this will be 1. If ahcfConfigObject… |
| 1.3.6.1.2.1.7777.1.1.1.5 | ColumnahcfConfigSampleType | read-create | current | The method of sampling the selected variable for storage in the ahcfSampleTable. If the value of this object is absoluteValue(1), the value of the selected var… |
| 1.3.6.1.2.1.7777.1.1.1.6 | ColumnahcfConfigObjectName | read-create | current | A printable string which describes the object being sampled. For example, if the object being sampled is the disk space usage defined in the Host Resources MIB… |
| 1.3.6.1.2.1.7777.1.1.1.7 | ColumnahcfConfigIdentifierVariables | read-create | current | One or more MIB variables which provide a unique identifier for the object oid to be sampled. This is meaningful only if the ahcfConfigObjectType is 'columnar'… |
| 1.3.6.1.2.1.7777.1.1.1.8 | ColumnahcfConfigFilterType | read-create | current | The type of filters specified for this config entry. This is meaningful only if the ahcfConfigObjectType is 'columnar'. If ahcfConfigFilterType is inclusive, a… |
| 1.3.6.1.2.1.7777.1.1.1.9 | ColumnahcfConfigFilterSpec1 | read-create | current | A filter for selecting the rows of a MIB table that need to be sampled. This is meaningful only if the ahcfConfigObjectType is 'columnar'. A filter can be spec… |
| 1.3.6.1.2.1.7777.1.1.1.10 | ColumnahcfConfigFilterSpec2 | read-create | current | A filter for specifying the rows of a MIB table that need to be sampled. Refer to description for ahcfConfigFilterSpec1 for details. |
| 1.3.6.1.2.1.7777.1.1.1.11 | ColumnahcfConfigFilterSpec3 | read-create | current | A filter for specifying the rows of a MIB table that need to be sampled. Refer to description for ahcfConfigFilterSpec1 for details. |
| 1.3.6.1.2.1.7777.1.1.1.12 | ColumnahcfConfigOwner | read-create | current | The entity that configured this entry and is therefore using the resources assigned to it. |
| 1.3.6.1.2.1.7777.1.1.1.13 | ColumnahcfConfigDefaultInterval | read-create | current | The default value to be used for ahcfInstanceInterval if a new row has to be created in ahcfInstanceTable for this config entry. If the ahcfConfigObjectType is… |
| 1.3.6.1.2.1.7777.1.1.1.14 | ColumnahcfConfigDefaultBucketsReq | read-create | current | The default value to be used for ahcfInstanceBucketsRequested if a new entry has to be created in ahcfInstanceTable for this config entry. If the ahcfConfigObj… |
| 1.3.6.1.2.1.7777.1.1.1.15 | ColumnahcfConfigStatus | read-create | current | The status of this variable history configuration entry. An entry MUST NOT exist in the active state unless all objects in the entry have an appropriate value.… |
| 1.3.6.1.2.1.7777.1.2 | TableahcfInstanceTable | not-accessible | current | List of MIB variable instances to be sampled based on the configuration in ahcfConfigTable. |
| 1.3.6.1.2.1.7777.1.2.1 | RowahcfInstanceEntry | not-accessible | current | A MIB instance to be sampled periodically. Entries in this table are created when an associated ahcfConfigEntry is created or new instances are detected for an… |
| 1.3.6.1.2.1.7777.1.2.1.1 | ColumnahcfInstanceIndex | not-accessible | current | An index used to uniquely identify an entry in the ahcfInstance table. Each such entry defines a MIB instance to be sampled periodically. |
| 1.3.6.1.2.1.7777.1.2.1.2 | ColumnahcfInstanceObjectVariable | read-only | current | The object identifier of the particular MIB instance to be sampled. If ahcfConfigObjectType is 'scalar', then this will be same as the ahcfConfigObjectVariable… |
| 1.3.6.1.2.1.7777.1.2.1.3 | ColumnahcfInstanceInterval | read-write | current | The interval in seconds over which the data is sampled for each bucket in the part of the ahcf table associated with this ahcfInstanceEntry. If the ahcfConfigO… |
| 1.3.6.1.2.1.7777.1.2.1.4 | ColumnahcfInstanceName | read-only | current | Unique name for the object instance being sampled. This value can be used by the management console when displaying the history statistics. The format of this … |
| 1.3.6.1.2.1.7777.1.2.1.5 | ColumnahcfInstanceBucketsRequested | read-write | current | The requested number of discrete time intervals over which data is to be saved in the part of the ahcfSampleTable associated with this ahcfConfigEntry. When th… |
| 1.3.6.1.2.1.7777.1.2.1.6 | ColumnahcfInstanceBucketsGranted | read-only | current | The number of discrete sampling intervals over which data shall be saved in the part of ahcfSampleTable associated with this ahcfConfigEntry. If the ahcfConfig… |
| 1.3.6.1.2.1.7777.1.2.1.7 | ColumnahcfInstanceLastSampleIndex | read-only | current | The value of ahcfSampleIndex for the most recent sample in the associated history. Zero if no samples have yet been taken. |
| 1.3.6.1.2.1.7777.1.2.1.8 | ColumnahcfInstanceTrendingState | read-write | current | The current state of history collection for the ahcfInstanceEntry. When the state is 'enabled', each sampled value will be added to the history. When the state… |
| 1.3.6.1.2.1.7777.1.2.1.9 | ColumnahcfInstanceThresholdState | read-write | current | The current state of threshold monitoring for this ahcfInstanceEntry. When the state is 'enabled', the sampled value will be compared to the configured thresho… |
| 1.3.6.1.2.1.7777.1.2.1.10 | ColumnahcfInstanceAlarmType | read-write | current | The alarm that may be sent when this entry is first set to valid. If the first sample after this entry becomes valid is greater than or equal to the risingThre… |
| 1.3.6.1.2.1.7777.1.2.1.11 | ColumnahcfInstanceAlarmSeverity | read-write | current | The type of the notification that needs to be sent for a threshold violation. The management console can use this value to identify the importance of a particu… |
| 1.3.6.1.2.1.7777.1.2.1.12 | ColumnahcfInstanceRisingThreshold | read-write | current | A threshold for the sampled variable. When the current sampled value is greater than or equal to this threshold, and the value at the last sampling interval wa… |
| 1.3.6.1.2.1.7777.1.2.1.13 | ColumnahcfInstanceFallingThreshold | read-write | current | A threshold for the sampled variable. When the current sampled value is less than or equal to this threshold, and the value at the last sampling interval was g… |
| 1.3.6.1.2.1.7777.1.2.1.14 | ColumnahcfInstanceStatus | read-write | current | The status of this ahcfInstanceEntry. ahcfInstanceEntry may be set to invalid, to modify one or more of ahcfInstanceInterval, ahcfInstanceBucketsRequested or a… |
| 1.3.6.1.2.1.7777.1.3 | TableahcfSampleTable | not-accessible | current | List of historical samples for user-defined MIB variables. |
| 1.3.6.1.2.1.7777.1.3.1 | RowahcfSampleEntry | not-accessible | current | Historical samples for a particular user-defined MIB variable. |
| 1.3.6.1.2.1.7777.1.3.1.1 | ColumnahcfSampleIndex | not-accessible | current | An index that uniquely identifies the particular sample this entry represents among all samples associated with the same ahcfConfigEntry. This index starts at … |
| 1.3.6.1.2.1.7777.1.3.1.2 | ColumnahcfSampleAbsValue | read-only | current | The absolute value (i.e. unsigned value) of the user- specified statistic during the last sampling period. The value during the current sampling period is not … |
| 1.3.6.1.2.1.7777.1.3.1.3 | ColumnahcfSampleValStatus | read-only | current | This object indicates the validity and sign of the data in the associated instance of ahcfSampleAbsValue. If the MIB instance could not be accessed during the … |
| 1.3.6.1.2.1.7777.1.3.1.4 | ColumnahcfSampleTimeStamp | read-only | current | This timestamp is the absolute date and time (UTC) that the sample was taken, expressed as seconds since midnight on January 1, 1970 If the probe keeps track o… |
| 1.3.6.1.2.1.7777.1.4 | NodeahcfSysInfo | |||
| 1.3.6.1.2.1.7777.1.4.1 | ScalarahcfSysTime | read-only | current | The date and time (UTC) on the SNMP probe. |
| 1.3.6.1.2.1.7777.1.4.2 | ScalarahcfSysTimeZone | read-only | current | The time zone in which this SNMP probe resides. The string is in the format - <Time Zone Name><Time Zone Offset> where 'Time Zone Offset' is +hh:mm or -hh:mm |
| 1.3.6.1.2.1.7777.1.4.3 | ScalarahcfSysDaylightSavings | read-only | current | Indicates whether daylight savings time is applicable or not. |
| 1.3.6.1.2.1.7777.2 | NodeahcfNotifications | |||
| 1.3.6.1.2.1.7777.2.0 | NodeahcfNotificationDefs | |||
| 1.3.6.1.2.1.7777.2.0.1 | NotificationahcfRisingAlarm | current | A rising alarm notification generated by the AHCF-MIB. When the ahcfInstanceThresholdState is 'enabled', the sampled value will be compared to the configured t… | |
| 1.3.6.1.2.1.7777.2.0.2 | NotificationahcfFallingAlarm | current | A falling alarm notification generated by the AHCF-MIB. Refer to the description of ahcfRisingAlarm for details. | |
| 1.3.6.1.2.1.7777.2.1 | NodeahcfNotificationInfo | |||
| 1.3.6.1.2.1.7777.2.1.1 | ScalarahcfProbeName | accessible-for-notify | current | The name of this probe |
| 1.3.6.1.2.1.7777.2.1.2 | ScalarahcfNotificationTime | accessible-for-notify | current | The UTC time in seconds at which the notification was generated. |
| 1.3.6.1.2.1.7777.2.1.3 | ScalarahcfRisingThreshold | accessible-for-notify | current | The rising threshold value specified by the user in the ahcfInstanceEntry for which this notification is generated. |
| 1.3.6.1.2.1.7777.2.1.4 | ScalarahcfFallingThreshold | accessible-for-notify | current | The falling threshold value specified by the user in the ahcfInstanceEntry for which this notification is generated. |
| 1.3.6.1.2.1.7777.2.1.5 | ScalarahcfInterval | accessible-for-notify | current | The sample interval in seconds specified by the user in the ahcfInstanceEntry for which this notification is generated. |
| 1.3.6.1.2.1.7777.2.1.6 | ScalarahcfInstanceId | accessible-for-notify | current | The descriptive name for the object instance sampled For example, if the object being sampled is the disk space usage defined in the hrStorageTable of Host Res… |
| 1.3.6.1.2.1.7777.2.1.7 | ScalarahcfAlarmSeverity | accessible-for-notify | current | The importance of the event (threshold violation) which resulted in the generation of this notification. The value used for this object is specified by the use… |
| 1.3.6.1.2.1.7777.3 | NodeahcfConformance | |||
| 1.3.6.1.2.1.7777.3.1 | NodeahcfCompliances | |||
| 1.3.6.1.2.1.7777.3.1.1 | ComplianceahcfCompliance | current | The compliance statement for SNMP entities that implement the AHCF-MIB. | |
| 1.3.6.1.2.1.7777.3.2 | NodeahcfGroups | |||
| 1.3.6.1.2.1.7777.3.2.1 | GroupahcfConfigGroup | current | Objects for data-collection configuration. | |
| 1.3.6.1.2.1.7777.3.2.2 | GroupahcfInstanceGroup | current | Objects for data-collection configuration of MIB instances based on the configuration in ahcfConfigTable. | |
| 1.3.6.1.2.1.7777.3.2.3 | GroupahcfSampleGroup | current | Objects for storing the historical samples. | |
| 1.3.6.1.2.1.7777.3.2.4 | GroupahcfSysInfoGroup | current | Objects providing the date, time and time zone of the agent machine. | |
| 1.3.6.1.2.1.7777.3.2.5 | GroupahcfNotificationDefsGroup | current | Objects defining the notifications generated by AHCF-MIB. | |
| 1.3.6.1.2.1.7777.3.2.6 | GroupahcfNotificationInfoGroup | current | Objects defining the notification variables for notifications generated by AHCF-MIB. |