BAS-RIP-MIB
72 objects
This module defines a portion of the proprietary management information base (MIB) for managing routing information protocol (RIP).
Imported Objects
| BAS-MIB | basRip |
| RFC1155-SMI | TimeTicks |
| SNMPv2-SMI | Counter32 IpAddress MODULE-IDENTITY OBJECT-TYPE |
| SNMPv2-TC | RowStatus TruthValue |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.4.1.3493.2.19.1 | IdentitybasRIP | This module defines a portion of the proprietary management information base (MIB) for managing routing information protocol (RIP). | ||
| 1.3.6.1.4.1.3493.2.19.1.1 | NoderipIfStatsCurGroup | |||
| 1.3.6.1.4.1.3493.2.19.1.1.1 | ScalarripIfResetTime | read-only | current | Time of last stats clear |
| 1.3.6.1.4.1.3493.2.19.1.1.2 | ScalarripIfStatsIntfCnt | read-only | current | Number of enabled interfaces running RIP |
| 1.3.6.1.4.1.3493.2.19.1.1.3 | ScalarripIfStatsNbrCnt | read-only | current | Total number of neighbors of all RIP interfaces |
| 1.3.6.1.4.1.3493.2.19.1.1.4 | ScalarripIfStatsPktsRcvd | read-only | current | Total number of RIP packets received on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.1.5 | ScalarripIfStatsPktsSent | read-only | current | Total number of RIP packets sent out on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.1.6 | ScalarripIfStatsReqsRcvd | read-only | current | Total number of RIP requests received on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.1.7 | ScalarripIfStatsReqsSent | read-only | current | Total number of RIP requests sent out on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.1.8 | ScalarripIfStatsRspsRcvd | read-only | current | Total number of RIP responses received on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.1.9 | ScalarripIfStatsRspsSent | read-only | current | Total number of RIP responses sent out on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.1.10 | ScalarripIfStatsRteTimouts | read-only | current | Total number of RIP routes timed out |
| 1.3.6.1.4.1.3493.2.19.1.1.11 | ScalarripIfStatsShrtPktsRcvd | read-only | current | Total number of RIP packets with size less than RIP header size received on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.1.12 | ScalarripIfStatsBadVerRcvd | read-only | current | Total number of RIP packets with version other than RIP version 1 or RIP version 2, received on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.1.13 | ScalarripIfStatsBadZeroRcvd | read-only | current | Total number of RIP packets with must be zero fields not set to zero, received on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.1.14 | ScalarripIfStatsBadSrcPortRcvd | read-only | current | Total number of RIP packets which did not originate from port 520, received on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.1.15 | ScalarripIfStatsBadSrcIpRcvd | read-only | current | Total number of RIP packets with invalid ip address, received on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.1.16 | ScalarripIfStatsPktsFrmSelfRcvd | read-only | current | Total number of RIP packets with receiver being the sender on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.1.17 | ScalarripIfStatsReset | read-write | current | Writing a 1 in ripIfStatsReset has the effect of clearing current RIP statistics |
| 1.3.6.1.4.1.3493.2.19.1.2 | NoderipIfStatsAllGroup | |||
| 1.3.6.1.4.1.3493.2.19.1.2.1 | ScalarripIfAllResetTime | read-only | current | Time since system reboot |
| 1.3.6.1.4.1.3493.2.19.1.2.2 | ScalarripIfAllStatsIntfCnt | read-only | current | Number of interfaces (enabled and disabled) running RIP |
| 1.3.6.1.4.1.3493.2.19.1.2.3 | ScalarripIfAllStatsNbrCnt | read-only | current | Total number of neighbors of all RIP interfaces |
| 1.3.6.1.4.1.3493.2.19.1.2.4 | ScalarripIfAllStatsPktsRcvd | read-only | current | Total number of RIP packets received on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.2.5 | ScalarripIfAllStatsPktsSent | read-only | current | Total number of RIP packets sent out on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.2.6 | ScalarripIfAllStatsReqsRcvd | read-only | current | Total number of RIP requests received on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.2.7 | ScalarripIfAllStatsReqsSent | read-only | current | Total number of RIP requests sent out on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.2.8 | ScalarripIfAllStatsRspsRcvd | read-only | current | Total number of RIP responses received on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.2.9 | ScalarripIfAllStatsRspsSent | read-only | current | Total number of RIP responses sent out on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.2.10 | ScalarripIfAllStatsRteTimouts | read-only | current | Total number of RIP routes timed out |
| 1.3.6.1.4.1.3493.2.19.1.2.11 | ScalarripIfAllStatsShrtPktsRcvd | read-only | current | Total number of RIP packets with size less than RIP header size received on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.2.12 | ScalarripIfAllStatsBadVerRcvd | read-only | current | Total number of RIP packets with version other than RIP version 1 or RIP version 2, received on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.2.13 | ScalarripIfAllStatsBadZeroRcvd | read-only | current | Total number of RIP packets with must be zero fields not set to zero, received on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.2.14 | ScalarripIfAllStatsBadSrcPortRcvd | read-only | current | Total number of RIP packets which did not originate from port 520, received on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.2.15 | ScalarripIfAllStatsBadSrcIpRcvd | read-only | current | Total number of RIP packets with invalid ip address, received on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.2.16 | ScalarripIfAllStatsPktsFrmSelfRcvd | read-only | current | Total number of RIP packets with receiver being the sender on all interfaces |
| 1.3.6.1.4.1.3493.2.19.1.3 | TablebasRipNbrTable | not-accessible | current | Neighbor table |
| 1.3.6.1.4.1.3493.2.19.1.3.1 | RowbasRipNbrEntry | not-accessible | current | A particular neighbour entry. |
| 1.3.6.1.4.1.3493.2.19.1.3.1.1 | ColumnripNbrIfIpAddr | not-accessible | current | Ip address on the RIP interface of which this is a neighbor |
| 1.3.6.1.4.1.3493.2.19.1.3.1.2 | ColumnripNbrIpAddr | not-accessible | current | Ip address of the neighbor |
| 1.3.6.1.4.1.3493.2.19.1.3.1.3 | ColumnripNbrAddressLessIf | read-only | current | If index of the RIP interface on this this is a neighbor |
| 1.3.6.1.4.1.3493.2.19.1.3.1.4 | ColumnripNbrType | read-only | current | Neighbor type is ripNbrTypeConfigured if it is configured on the interface. A neighbor is of type discovered it is not configured and updates from this neighbo… |
| 1.3.6.1.4.1.3493.2.19.1.3.1.5 | ColumnripNbrLastUpdate | read-only | current | Time simce last update was received from this neighbor |
| 1.3.6.1.4.1.3493.2.19.1.3.1.6 | ColumnripNbrTriggerMode | read-only | current | Indicates if the neighbor is triggered or not |
| 1.3.6.1.4.1.3493.2.19.1.3.1.7 | ColumnripNbrRowStatus | read-write | current | Administrative control to creat and delete a neighbor |
| 1.3.6.1.4.1.3493.2.19.1.4 | TablebasRipIfTable | not-accessible | current | This is used for proprietry interface info. |
| 1.3.6.1.4.1.3493.2.19.1.4.1 | RowbasRipIfEntry | not-accessible | current | Interface configuration entry. |
| 1.3.6.1.4.1.3493.2.19.1.4.1.1 | ColumnripIfIpAddress | read-write | current | Ip address of the interface running RIP |
| 1.3.6.1.4.1.3493.2.19.1.4.1.2 | ColumnripIfAddressLessIf | read-write | current | IfIndex of the interface running RIP |
| 1.3.6.1.4.1.3493.2.19.1.4.1.3 | ColumnripIfType | read-write | current | Type of the interface running RIP |
| 1.3.6.1.4.1.3493.2.19.1.4.1.4 | ColumnripIfVersion | read-write | current | What the router sends on this interface. ripVersion1 implies sending RIP updates compliant with RFC 1058. ripSendCompat implies broadcasting RIP-2 updates usin… |
| 1.3.6.1.4.1.3493.2.19.1.4.1.5 | ColumnripIfRecvVer | read-write | current | This indicates which version of RIP updates are to be accepted. Note that ripRcvVer2 and ripRcvVer1and2 implies reception of multicast packets. |
| 1.3.6.1.4.1.3493.2.19.1.4.1.6 | ColumnripIfMetric | read-write | current | Value of metric corresponding to this interface. Metric value will be added to all routes leared from this interface |
| 1.3.6.1.4.1.3493.2.19.1.4.1.7 | ColumnripIfAcceptDefault | read-write | current | If ripIfAcceptDefault is TRUE then default routes will be accepted on this interface |
| 1.3.6.1.4.1.3493.2.19.1.4.1.8 | ColumnripIfSilent | read-write | current | If ripIfSilent is TRUE then no RIP updates would be sent of by this interface |
| 1.3.6.1.4.1.3493.2.19.1.4.1.9 | ColumnripIfRecvRoutes | read-write | current | If ripIfRecvRoutes is TRUE then RIP updates received on this interface are disregarded |
| 1.3.6.1.4.1.3493.2.19.1.4.1.10 | ColumnripIfSubnetsOnly | read-write | current | If ripIfSubnetsOnly is TRUE, then |
| 1.3.6.1.4.1.3493.2.19.1.4.1.11 | ColumnripIfSendDefaultOnly | read-write | current | If ripIfSendDefaultOnly is TRUE, RIP update from this interface would consist of only the default route |
| 1.3.6.1.4.1.3493.2.19.1.4.1.12 | ColumnripIfSendDefaultAlso | read-write | current | If ripIfSendDefaultAlso is TRUE, RIP update from this interface would consist of default route along with other routes |
| 1.3.6.1.4.1.3493.2.19.1.4.1.13 | ColumnripIfDfltRouteMetric | read-write | current | This variable indicates the metric that is to be used for the default route entry in RIP updates originated on this interface. |
| 1.3.6.1.4.1.3493.2.19.1.4.1.14 | ColumnripIfSplitHorizon | read-write | current | If ripIfSplitHorizon is TRUE, enables split horizon processing as defined in RFC 1058 |
| 1.3.6.1.4.1.3493.2.19.1.4.1.15 | ColumnripIfPoison | read-write | current | In ripIfPoison is TRUE, enables Poison reverse updates on this interface. (Poison reverse is defined in RCF 1058) |
| 1.3.6.1.4.1.3493.2.19.1.4.1.16 | ColumnripIfFlash | read-write | current | if ripIfFlash is TRUE flash updates will be sent out from this interface following a route change |
| 1.3.6.1.4.1.3493.2.19.1.4.1.17 | ColumnripAuthOn | read-write | current | If ripAuthOn TRUE enables authentication on this interface. All updates generated from this interface would be authenticated using specified authentication typ… |
| 1.3.6.1.4.1.3493.2.19.1.4.1.18 | ColumnripIfAuthType | read-write | current | The type of Authentication used on this interface. |
| 1.3.6.1.4.1.3493.2.19.1.4.1.19 | ColumnripIfAuthKeyId | read-write | current | md5 authentication keyid used for this interface. RFC2082 describes md5 authentication and keyids |
| 1.3.6.1.4.1.3493.2.19.1.4.1.20 | ColumnripIfAuthKey | read-write | current | The value to be used as the Authentication Key whenever the corresponding instance of ripIfAuthType has a value other than noAuthentication. A modification of … |
| 1.3.6.1.4.1.3493.2.19.1.4.1.21 | ColumnripIfUpdateInterval | read-only | current | Time between 2 RIP updates for this interface |
| 1.3.6.1.4.1.3493.2.19.1.4.1.22 | ColumnripIfUpdateInterPktGap | read-only | current | Time between sending 2 packets of the same RIP update when update is more than 1 packet |
| 1.3.6.1.4.1.3493.2.19.1.4.1.23 | ColumnripIfPktsPerUpdate | read-only | current | Maximum number of packets allowed per update on this interface |
| 1.3.6.1.4.1.3493.2.19.1.4.1.24 | ColumnripIfPortDown | read-only | current | Indicates if port on which this interface exists is down. |
| 1.3.6.1.4.1.3493.2.19.1.4.1.25 | ColumnripIfRowStat | read-write | current | Administrative control over, creation and enabling RIP interface |