MIB Viewer

CABH-IETF-SEC-MIB

78 objects
This MIB module supplies the basic management objects for the Security Portal Services. Copyright (C) The Internet Society (2003). This version of this MIB module is part of RFC xxxx; see the RFC itself for full legal notices.
Imported Objects
DOCS-BPI2-MIB--RFC2571 DocsX509ASN1DEREncodedCertificate
DOCS-CABLE-DEVICE-MIBdocsDevFilterIpEntry
INET-ADDRESS-MIB-- RFC2580 InetPortNumber InetAddress InetAddressType
RMON2-MIBtxt or after ZeroBasedCounter32
SNMP-FRAMEWORK-MIB--RFC3291 SnmpAdminString
SNMPv2-CONF-- RFC2579 OBJECT-GROUP MODULE-COMPLIANCE
SNMPv2-SMImib-2 MODULE-IDENTITY OBJECT-TYPE Unsigned32 zeroDotZero
SNMPv2-TC-- RFC2578 DateAndTime TimeStamp TruthValue VariablePointer
OIDNameAccessStatusDescription
1.3.6.1.2.1IdentitycabhSecMibThis MIB module supplies the basic management objects for the Security Portal Services. Copyright (C) The Internet Society (2003). This version of this MIB mod…
1.3.6.1.2.1.1NodecabhSecMibObjects
1.3.6.1.2.1.1.1NodecabhSecFwObjects
1.3.6.1.2.1.1.1.1NodecabhSecFwBase
1.3.6.1.2.1.1.1.1.1ScalarcabhSecFwPolicyFileEnableread-writecurrentThis parameter indicates whether or not to enable the firewall functionality.
1.3.6.1.2.1.1.1.1.2ScalarcabhSecFwPolicyFileURLread-writecurrentContains the location of the last successfull downloaded policy rule set file in the format pointed in the reference. A policy rule set file download is trigge…
1.3.6.1.2.1.1.1.1.3ScalarcabhSecFwPolicyFileHashread-writecurrentHash of the contents of the rules set file, calculated and sent to the PS prior to sending the rules set file. For the SHA-1 authentication algorithm the lengt…
1.3.6.1.2.1.1.1.1.4ScalarcabhSecFwPolicyFileOperStatusread-onlycurrentinProgress(1) indicates a firewall configuration file download is underway. complete (2) indicates the firewall configuration file downloaded and configured su…
1.3.6.1.2.1.1.1.1.5ScalarcabhSecFwPolicyFileCurrentVersionread-onlycurrentThe rule set version currently operating in the PS device. This object should be in the syntax used by the individual vendor to identify software versions. Any…
1.3.6.1.2.1.1.1.1.6ScalarcabhSecFwPolicySuccessfulFileURLread-onlycurrentContains the location of the last successfull downloaded policy rule set file in the format pointed in the reference. If a successful download has not yet occu…
1.3.6.1.2.1.1.1.2NodecabhSecFwLogCtl
1.3.6.1.2.1.1.1.2.1ScalarcabhSecFwEventType1Enableread-writecurrentThis object enables or disables logging of type 1 firewall event messages. Type 1 event messages report attempts from both private and public clients to traver…
1.3.6.1.2.1.1.1.2.2ScalarcabhSecFwEventType2Enableread-writecurrentThis object enables or disables logging of type 2 firewall event messages. Type 2 event messages report identified Denial of Service attack attempts.
1.3.6.1.2.1.1.1.2.3ScalarcabhSecFwEventType3Enableread-writecurrentEnables or disables logging of type 3 firewall event messages. Type 3 event messages report changes made to the following firewall management parameters: cabhS…
1.3.6.1.2.1.1.1.2.4ScalarcabhSecFwEventAttackAlertThresholdread-writecurrentIf the number of type 1 or 2 hacker attacks exceeds this threshold in the period define by cabhSecFwEventAttackAlertPeriod, a firewall message event MUST be lo…
1.3.6.1.2.1.1.1.2.5ScalarcabhSecFwEventAttackAlertPeriodread-writecurrentIndicates the period to be used (in hours) for the cabhSecFwEventAttackAlertThreshold. This MIB variable should always keep track of the last x hours of events…
1.3.6.1.2.1.1.2NodecabhSecCertObjects
1.3.6.1.2.1.1.2.1ScalarcabhSecCertPsCertread-onlycurrentThe X509 DER-encoded PS certificate.
1.3.6.1.2.1.1.3NodecabhSecKerbObjects
1.3.6.1.2.1.1.3.1NodecabhSecKerbBase
1.3.6.1.2.1.1.3.1.1ScalarcabhSecKerbPKINITGracePeriodread-writecurrentThe PKINIT Grace Period is needed by the PS to know when it should start retrying to get a new ticket. The PS MUST obtain a new Kerberos ticket (with a PKINIT …
1.3.6.1.2.1.1.3.1.2ScalarcabhSecKerbTGSGracePeriodread-writecurrentThe TGS Grace Period is needed by the PS to know when it should start retrying to get a new ticket. The PS MUST obtain a new Kerberos ticket (with a TGS Reques…
1.3.6.1.2.1.1.3.1.3ScalarcabhSecKerbUnsolicitedKeyMaxTimeoutread-writecurrentThis timeout applies to PS initiated AP-REQ/REP key management exchange with NMS. The maximum timeout is the value which may not be exceeded in the exponential…
1.3.6.1.2.1.1.3.1.4ScalarcabhSecKerbUnsolicitedKeyMaxRetriesread-writecurrentThe number of retries the PS is allowed for AP-REQ/REP key management exchange initiation with the NMS. This is the maximum number of retries before the PS giv…
1.3.6.1.2.1.1.4NodecabhSec2FwObjects
1.3.6.1.2.1.1.4.1NodecabhSec2FwBase
1.3.6.1.2.1.1.4.1.1ScalarcabhSec2FwEnableread-writecurrentThis parameter indicates whether to enable or disable the firewall.
1.3.6.1.2.1.1.4.1.2ScalarcabhSec2FwPolicyFileURLread-writecurrentContains the location of the last successfull downloaded policy rule set file in the format pointed in the reference. A policy rule set file download is trigge…
1.3.6.1.2.1.1.4.1.3ScalarcabhSec2FwPolicyFileHashread-writecurrentHash of the contents of the firewall configuration file. For the SHA-1 authentication algorithm the length of the hash is 160 bits. This hash value is encoded …
1.3.6.1.2.1.1.4.1.4ScalarcabhSec2FwPolicyFileOperStatusread-onlycurrentInProgress(1) indicates a firewall configuration file download is underway. Complete(2) indicates the firewall configuration file was downloaded and processed …
1.3.6.1.2.1.1.4.1.5ScalarcabhSec2FwPolicyFileCurrentVersionread-writecurrentA label set by the cable operator that can be used to track various versions of configured rulesets. Once the label is set it and configured rules are changed,…
1.3.6.1.2.1.1.4.1.6ScalarcabhSec2FwClearPreviousRulesetread-writecurrentAllows PS or firewall configuration files to contain either a complete firewall configured ruleset or an incremental to the already established configured rule…
1.3.6.1.2.1.1.4.1.7ScalarcabhSec2FwPolicySelectionread-writecurrentThis parameter indicates which policy should currently be running in the firewall, either the factoryDefault policy or the configuredRuleset.
1.3.6.1.2.1.1.4.1.8ScalarcabhSec2FwEventSetToFactoryread-writecurrentIf set to 'true', entries in cabhSec2FwEventControlEntry are set to their default values. Reading this value always returns false.
1.3.6.1.2.1.1.4.1.9ScalarcabhSec2FwEventLastSetToFactoryread-onlycurrentThe value of sysUpTime when cabhSec2FwEventSetToFactory was last set to true. Zero if never reset.
1.3.6.1.2.1.1.4.1.10ScalarcabhSec2FwPolicySuccessfulFileURLread-onlycurrentContains the location of the last successfull downloaded policy rule set file in the format pointed in the reference. If a successful download has not yet occu…
1.3.6.1.2.1.1.4.2NodecabhSec2FwEvent
1.3.6.1.2.1.1.4.2.1TablecabhSec2FwEventControlTablenot-accessiblecurrentThis table controls the reporting of the Firewall Attacks events
1.3.6.1.2.1.1.4.2.1.1RowcabhSec2FwEventControlEntrynot-accessiblecurrentAllows configuration of the reporting mechanisms for a particular type of attack.
1.3.6.1.2.1.1.4.2.1.1.1ColumncabhSec2FwEventTypenot-accessiblecurrentClassification of the different types of attacks. Type 1 logs all attempts from both LAN and WAN clients to traverse the Firewall that violate the Security Pol…
1.3.6.1.2.1.1.4.2.1.1.2ColumncabhSec2FwEventEnableread-writecurrentEnables or disables counting and logging of firewall events by type as assigned by cabhSec2FwEventType.
1.3.6.1.2.1.1.4.2.1.1.3ColumncabhSec2FwEventThresholdread-writecurrentNumber of attacks to count before sending the appropriate event by type as assigned by cabhSec2FwEventType.
1.3.6.1.2.1.1.4.2.1.1.4ColumncabhSec2FwEventIntervalread-writecurrentIndicates the time interval in hours to count and log occurrences of a firewall event type as assigned in cabhSec2FwEventType. If this MIB has a value of zero …
1.3.6.1.2.1.1.4.2.1.1.5ColumncabhSec2FwEventCountread-onlycurrentIndicates the current count up to the cabhSec2FwEventThreshold value by type as assigned by cabhSec2FwEventType.
1.3.6.1.2.1.1.4.2.1.1.6ColumncabhSec2FwEventLogResetread-writecurrentSetting this object to true clears the log table for the specified event type. Reading this object always returns false.
1.3.6.1.2.1.1.4.2.1.1.7ColumncabhSec2FwEventLogLastResetread-onlycurrentThe value of sysUpTime when cabhSec2FwEventLogReset was last set to true. Zero if never reset.
1.3.6.1.2.1.1.4.3NodecabhSec2FwLog
1.3.6.1.2.1.1.4.3.1TablecabhSec2FwLogTablenot-accessiblecurrentContains a log of packet information as related to events enabled by the cable operator. The types are defined in the CableHome 1.1 specification and require v…
1.3.6.1.2.1.1.4.3.1.1RowcabhSec2FwLogEntrynot-accessiblecurrentEach entry contains the log of firewall events
1.3.6.1.2.1.1.4.3.1.1.1ColumncabhSec2FwLogIndexnot-accessiblecurrentA sequence number for the specific events under a cabhSec2FwEventType.
1.3.6.1.2.1.1.4.3.1.1.2ColumncabhSec2FwLogEventTyperead-onlycurrentClassification of the different types of attacks. Type 1 logs all attempts from both LAN and WAN clients to traverse the Firewall that violate the Security Pol…
1.3.6.1.2.1.1.4.3.1.1.3ColumncabhSec2FwLogEventPriorityread-onlycurrentThe priority level of this event as defined by CableHome Specification. If a priority is not assigned in the CableHome specification for a particular event the…
1.3.6.1.2.1.1.4.3.1.1.4ColumncabhSec2FwLogEventIdread-onlycurrentThe assigned event ID.
1.3.6.1.2.1.1.4.3.1.1.5ColumncabhSec2FwLogTimeread-onlycurrentThe time that this entry was created by the PS.
1.3.6.1.2.1.1.4.3.1.1.6ColumncabhSec2FwLogIpProtocolread-onlycurrentThe IP Protocol
1.3.6.1.2.1.1.4.3.1.1.7ColumncabhSec2FwLogIpAddrTyperead-onlycurrentThe type of IP addresses in the packet
1.3.6.1.2.1.1.4.3.1.1.8ColumncabhSec2FwLogIpSourceAddrread-onlycurrentThe Source IP Address of the packet logged. The address type of this object is specified by cabhSec2FwLogIpAddrType.
1.3.6.1.2.1.1.4.3.1.1.9ColumncabhSec2FwLogIpDestAddrread-onlycurrentThe Destination IP Address of the packet logged. The address type of this object is specified by cabhSec2FwLogIpAddrType.
1.3.6.1.2.1.1.4.3.1.1.10ColumncabhSec2FwLogIpSourcePortread-onlycurrentThe Source IP Port of the packet logged
1.3.6.1.2.1.1.4.3.1.1.11ColumncabhSec2FwLogIpDestPortread-onlycurrentThe Source IP Port of the packet logged
1.3.6.1.2.1.1.4.3.1.1.12ColumncabhSec2FwLogMessageTyperead-onlycurrentThe ICMP defined types.
1.3.6.1.2.1.1.4.3.1.1.13ColumncabhSec2FwLogReplayCountread-onlycurrentThe number of identical attack packets that were seen by the firewall based on cabhSec2FwLogIpProtocol, cabhSec2FwLogIpSourceAddr, cabhSec2FwLogIpDestAddr, cab…
1.3.6.1.2.1.1.4.3.1.1.14ColumncabhSec2FwLogMIBPointerread-onlycurrentIdentifies if the cabhSec2FwPolicyFileURL or the cabhSec2FwEnable MIB object changed or an attempt was made to change it.
1.3.6.1.2.1.1.4.4NodecabhSec2FwFilter
1.3.6.1.2.1.1.4.4.1TablecabhSec2FwFilterScheduleTablenot-accessiblecurrentExtends the filtering matching parameters of docsDevFilterIpTable defined in RFC 2669 for CableHome Residential Gateways to include time day intervals and days…
1.3.6.1.2.1.1.4.4.1.1RowcabhSec2FwFilterScheduleEntrynot-accessiblecurrentExtended values for entries of docsDevFilterIpTable. If the PS has not acquired ToD the entire docsDevFilterIpEntry rule set is ignored.
1.3.6.1.2.1.1.4.4.1.1.1ColumncabhSec2FwFilterScheduleStartTimeread-createcurrentThe start time, with optional time zone, for a firewall filter ruleset. Only the time portion of the DateAndTime TEXTUAL-CONVENTION have a meaning.
1.3.6.1.2.1.1.4.4.1.1.2ColumncabhSec2FwFilterScheduleEndTimeread-createcurrentThe end time, with optional time zone, for a firewall filter ruleset. Only the time portion of the DateAndTime TEXTUAL-CONVENTION have a meaning.
1.3.6.1.2.1.1.4.4.1.1.3ColumncabhSec2FwFilterScheduleDOWread-createcurrentIf the day of week bit associated with the PS given day is '1', this object criteria matches.
1.3.6.1.2.1.2NodecabhSecNotification
1.3.6.1.2.1.3NodecabhSecConformance
1.3.6.1.2.1.3.1NodecabhSecCompliances
1.3.6.1.2.1.3.1.1CompliancecabhSecCompliancecurrentThe compliance statement for CableHome Security.
1.3.6.1.2.1.3.2NodecabhSecGroups
1.3.6.1.2.1.3.2.1GroupcabhSecGroupcurrentGroup of objects in CableHome 1.0 Firewall MIB.
1.3.6.1.2.1.3.2.2GroupcabhSecCertGroupcurrentGroup of objects in CableHome gateway for PS Certificate.
1.3.6.1.2.1.3.2.3GroupcabhSecKerbGroupcurrentGroup of objects in CableHome gateway for Kerberos.
1.3.6.1.2.1.3.2.4GroupcabhSec2GroupcurrentGroup of objects in CableHome 1.1 Firewall MIB.