MIB Viewer

DSG-IF-STD-MIB

83 objects
Licensed under the Apache License, Version 2.0 (the 'License'); you may not use this file except in compliance with the License. You may obtain a copy of the License at: http://www.apache.org/licenses/LICENSE-2.0 Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an 'AS IS' BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License. This MIB module provides the management objects of the DOCSIS Set-top Gateway (DSG) client controller CM component for DSG operations of Set-top devices. Copyright 1999-2023 Cable Television Laboratories, Inc. All rights reserved.
Imported Objects
CLAB-DEF-MIBclabProjDocsis
DOCS-CABLE-DEVICE-MIB-- RFC 2863 docsDevEvLevel docsDevEvId docsDevEvText
DOCS-IF-MIB-- RFC 4639 docsIfCmCmtsAddress docsIfCmStatusDocsisOperMode docsIfCmStatusModulationType docsIfDocsisBaseCapability
DOCS-IF3-MIBDsid
IF-MIB-- RFC 3291 ifPhysAddress
INET-ADDRESS-MIB-- RFC 2579 InetAddressType InetAddress InetPortNumber
SNMPv2-CONF--RFC 2578 OBJECT-GROUP MODULE-COMPLIANCE NOTIFICATION-GROUP
SNMPv2-SMICounter32 Integer32 MODULE-IDENTITY NOTIFICATION-TYPE OBJECT-TYPE Unsigned32
SNMPv2-TC-- RFC 2580 MacAddress TruthValue
OIDNameAccessStatusDescription
1.3.6.1.4.1.4491.2.1.4IdentitydsgIfStdMibLicensed under the Apache License, Version 2.0 (the 'License'); you may not use this file except in compliance with the License. You may obtain a copy of the L…
1.3.6.1.4.1.4491.2.1.4.0NodedsgIfStdNotifications
1.3.6.1.4.1.4491.2.1.4.0.1NotificationdsgIfStdUpstreamEnabledNotifycurrentIndicates the eCM is being instructed to have the upstream transmitter enabled. This notification is send after CM registration. Note that the objects docsIfDo…
1.3.6.1.4.1.4491.2.1.4.0.2NotificationdsgIfStdUpstreamDisabledNotifycurrentIndicates the CM is being instructed to have the upstream transmitter disabled. This notification is only send when the CM is registered and prior to disable t…
1.3.6.1.4.1.4491.2.1.4.0.3NotificationdsgIfStdTdsg2TimeoutNotifycurrentNotifies that the eCM has a timeout Tdsg2. Note that the objects docsIfDocsisBaseCapability, docsIfCmStatusDocsisOperMode and docsIfCmStatusModulationType may …
1.3.6.1.4.1.4491.2.1.4.1NodedsgIfStdMibObjects
1.3.6.1.4.1.4491.2.1.4.1.1NodedsgIfStdConfig
1.3.6.1.4.1.4491.2.1.4.1.1.1ScalardsgIfStdDsgModeread-onlycurrentThe DSG Mode of operation of this device. The value 'none' indicates that the eCM is not performing DSG operations.
1.3.6.1.4.1.4491.2.1.4.1.1.2ScalardsgIfStdTdsg1read-onlycurrentThe configured value for the Tdsg1 timer.
1.3.6.1.4.1.4491.2.1.4.1.1.3ScalardsgIfStdTdsg2read-onlycurrentThe configured value for the Tdsg2 timer.
1.3.6.1.4.1.4491.2.1.4.1.1.4ScalardsgIfStdTdsg3read-onlycurrentThe configured value for the Tdsg3 timer.
1.3.6.1.4.1.4491.2.1.4.1.1.5ScalardsgIfStdTdsg4read-onlycurrentThe configured value for the Tdsg4 timer.
1.3.6.1.4.1.4491.2.1.4.1.1.6ScalardsgIfStdTdsg1Timeoutsread-onlycurrentThe number of times Tdsg1 expired in the DSG eCM since last reboot.
1.3.6.1.4.1.4491.2.1.4.1.1.7ScalardsgIfStdTdsg2Timeoutsread-onlycurrentThe number of times Tdsg2 expired in the DSG eCM since last reboot.
1.3.6.1.4.1.4491.2.1.4.1.1.8ScalardsgIfStdTdsg3Timeoutsread-onlycurrentThe number of times Tdsg3 expired in the DSG eCM since last reboot.
1.3.6.1.4.1.4491.2.1.4.1.1.9ScalardsgIfStdTdsg4Timeoutsread-onlycurrentThe number of times Tdsg4 expired in the DSG eCM since last reboot.
1.3.6.1.4.1.4491.2.1.4.1.1.10ScalardsgIfStdOneWayRecoveryread-writecurrentThis objects describes what the eCM does when the Tdsg3 timer expires. A value of retryUp(1) indicates that the eCM will remain on the current downstream chann…
1.3.6.1.4.1.4491.2.1.4.1.2NodedsgIfStdTunnelFilter
1.3.6.1.4.1.4491.2.1.4.1.2.1TabledsgIfStdTunnelFilterTablenot-accessiblecurrentA table of the active DSG Tunnel Filters. Each DSG Tunnel Filter is used to identify packets to forward to a DSG Client. Conceptually, each DSG Tunnel is compo…
1.3.6.1.4.1.4491.2.1.4.1.2.1.1RowdsgIfStdTunnelFilterEntrynot-accessiblecurrentThe DSG eCM will have one entry for each DSG Tunnel Filter. One or more entries in this table are created when the DSG Client Controller instructs the eCM to b…
1.3.6.1.4.1.4491.2.1.4.1.2.1.1.1ColumndsgIfStdTunnelFilterIndexnot-accessiblecurrentThe unique index of entries in this table.
1.3.6.1.4.1.4491.2.1.4.1.2.1.1.2ColumndsgIfStdTunnelFilterApplicationIdread-onlydeprecatedThe Application ID of the DSG Tunnel associated with this DSG Tunnel Filter. This object returns -1 for: DSG Tunnels that do not have an associated Application…
1.3.6.1.4.1.4491.2.1.4.1.2.1.1.3ColumndsgIfStdTunnelFilterMacAddressread-onlycurrentThe destination MAC Address matching this DSG Tunnel Filter entry.
1.3.6.1.4.1.4491.2.1.4.1.2.1.1.4ColumndsgIfStdTunnelFilterIpAddressTyperead-onlycurrentThe type of InetAddress for dsgIfStdTunnelFilterSrcIpAddr, dsgIfStdTunnelFilterSrcIpMask and dsgIfStdTunnelFilterDestIpAddr. Currently DSG Agents, DSG Client C…
1.3.6.1.4.1.4491.2.1.4.1.2.1.1.5ColumndsgIfStdTunnelFilterSrcIpAddrread-onlycurrentThe source IP Address matching this DSG Tunnel Filter. This object is used in conjunction with dsgIfStdTunnelFilterSrcMask. A value of zero indicates that sour…
1.3.6.1.4.1.4491.2.1.4.1.2.1.1.6ColumndsgIfStdTunnelFilterSrcIpMaskread-onlycurrentThe Source IP Mask to be used with dsgIfStdTunnelFilterSrcIpAddr when comparing a packet to this DSG Tunnel Filter. The type of this address is determined by t…
1.3.6.1.4.1.4491.2.1.4.1.2.1.1.7ColumndsgIfStdTunnelFilterDestIpAddrread-onlycurrentThe destination IP Address matching this DSG Tunnel Filter. A value of zero indicates that destination IP Address filtering does not apply. The type of this ad…
1.3.6.1.4.1.4491.2.1.4.1.2.1.1.8ColumndsgIfStdTunnelFilterDestPortStartread-onlycurrentThe lower UDP destination port value in the range matching this DSG Tunnel Filter.
1.3.6.1.4.1.4491.2.1.4.1.2.1.1.9ColumndsgIfStdTunnelFilterDestPortEndread-onlycurrentThe upper UDP destination port value in the range matching this DSG Tunnel Filter.
1.3.6.1.4.1.4491.2.1.4.1.2.1.1.10ColumndsgIfStdTunnelFilterPktsread-onlycurrentThe total number of Packets matching this DSG Tunnel Filter entry since creation of the entry.
1.3.6.1.4.1.4491.2.1.4.1.2.1.1.11ColumndsgIfStdTunnelFilterOctetsread-onlycurrentThe total number of octets matching this DSG Tunnel Filter entry since creation of the entry.
1.3.6.1.4.1.4491.2.1.4.1.2.1.1.12ColumndsgIfStdTunnelFilterTimeActiveread-onlycurrentThe total number of seconds that this DSG Tunnel Filter entry has been instantiated.
1.3.6.1.4.1.4491.2.1.4.1.2.1.1.13ColumndsgIfStdTunnelFilterTunnelIdread-onlycurrentIn DSG Advanced Mode, this value identifies the DSG Tunnel corresponding to this DSG Tunnel Filter entry. This value may correspond to the DSG Rule ID from the…
1.3.6.1.4.1.4491.2.1.4.1.2.1.1.14ColumndsgIfStdTunnelFilterDsidread-onlycurrentWhen operating with Multicast DSID Forwarding (MDF) enabled, this object contains the DSID value obtained from the DA-to-DSID TLV in the MDD. If no DSID has be…
1.3.6.1.4.1.4491.2.1.4.1.2.1.1.15ColumndsgIfStdTunnelFilterClientIdTyperead-onlycurrentThe value of cableCard(0) indicates a DSG Tunnel requested by the CableCARD on an OpenCable Host. The value of broadcast(1) indicates a DSG Tunnel for an indus…
1.3.6.1.4.1.4491.2.1.4.1.2.1.1.16ColumndsgIfStdTunnelFilterClientIdValueread-onlycurrentThe Client Identification Value. The content depends on the value of the dsgIfStdTunnelFilterClientIdType. For dsgIfStdTunnelFilterClientIdType of type cableCa…
1.3.6.1.4.1.4491.2.1.4.1.3NodedsgIfStdDsgChannelList
1.3.6.1.4.1.4491.2.1.4.1.3.1TabledsgIfStdDsgChannelListTablenot-accessiblecurrentThis table contains the list of DSG channels provided to the DSG eCM for use in scanning.
1.3.6.1.4.1.4491.2.1.4.1.3.1.1RowdsgIfStdDsgChannelListEntrynot-accessiblecurrentThe conceptual row for this table. The DSG eCM creates an entry per each downstream channel provided in the DCD message. An entry is deleted when removed from …
1.3.6.1.4.1.4491.2.1.4.1.3.1.1.1ColumndsgIfStdDsgChannelListIndexnot-accessiblecurrentThe unique identifier for entries in this table
1.3.6.1.4.1.4491.2.1.4.1.3.1.1.2ColumndsgIfStdDsgChannelListFrequencyread-onlycurrentThe downstream channel center frequency of this entry.
1.3.6.1.4.1.4491.2.1.4.1.4NodedsgIfStdDsgSeb
1.3.6.1.4.1.4491.2.1.4.1.4.1ScalardsgIfStdDsgSebControlObjectread-writecurrentThis object controls the state of DSG SEB. When set to FALSE the device is prohibited from enabling DSG SEB, both as a client or a server.
1.3.6.1.4.1.4491.2.1.4.1.4.2ScalardsgIfStdDsgSebRoleread-onlycurrentThis object reports the current role of this device. The value of disabled(1) is used for a device where SEB is administratively disabled. The value of sebServ…
1.3.6.1.4.1.4491.2.1.4.1.4.3ScalardsgIfStdDsgSebFomWeightUpstreamPowerread-writecurrentThis object controls the contribution of the upstream transmit power level term for the Figure of Merit Calculation.
1.3.6.1.4.1.4491.2.1.4.1.4.4ScalardsgIfStdDsgSebFomWeightDownstreamPowerread-writecurrentThis object controls the contribution of the downstream receive power level term for the Figure of Merit Calculation.
1.3.6.1.4.1.4491.2.1.4.1.4.5ScalardsgIfStdDsgSebFomWeightEqualizerread-writecurrentThis object controls the contribution of the equalizer performance term for the Figure of Merit Calculation.
1.3.6.1.4.1.4491.2.1.4.1.4.6ScalardsgIfStdDsgSebFomUsPwrHrread-writecurrentThis object defines the Upstream transmit power headroom value for the Figure of Merit Calculation.
1.3.6.1.4.1.4491.2.1.4.1.4.7ScalardsgIfStdDsgSebFomMfQpskread-writecurrentThis object defines the value of maximum power level for QPSK upstream for the Figure of Merit Calculation.
1.3.6.1.4.1.4491.2.1.4.1.4.8ScalardsgIfStdDsgSebFomMfQam16read-writecurrentThis object defines the value of maximum power level for QAM16 upstream for the Figure of Merit Calculation.
1.3.6.1.4.1.4491.2.1.4.1.4.9ScalardsgIfStdDsgSebFomMfQam64read-writecurrentThis object defines the value of maximum power level for QAM64 upstream for the Figure of Merit Calculation.
1.3.6.1.4.1.4491.2.1.4.1.4.10ScalardsgIfStdDsgSebFomDsDesPwrread-writecurrentThis object defines the value of desired downstream receive power for the Figure of Merit Calculation.
1.3.6.1.4.1.4491.2.1.4.1.4.11ScalardsgIfStdDsgSebFomDspMinread-writecurrentThis object defines the value of downstream receive power minimum for the Figure of Merit Calculation.
1.3.6.1.4.1.4491.2.1.4.1.4.12ScalardsgIfStdDsgSebFomDspMaxread-writecurrentThis object defines the value of downstream receive power maximum for the Figure of Merit Calculation.
1.3.6.1.4.1.4491.2.1.4.1.4.13ScalardsgIfStdDsgSebFomNmteRngread-writecurrentThis object defines the value of non-main tap energy range for the Figure of Merit Calculation.
1.3.6.1.4.1.4491.2.1.4.1.4.14ScalardsgIfStdDsgSebFomNmteMaxread-writecurrentThis object defines the value of non-main tap energy maximum for the Figure of Merit Calculation.
1.3.6.1.4.1.4491.2.1.4.1.4.15ScalardsgIfStdDsgSebFomMtcMinread-writecurrentThis object defines the value of main tap compression minimum for the Figure of Merit Calculation.
1.3.6.1.4.1.4491.2.1.4.1.4.16ScalardsgIfStdDsgSebFomread-onlycurrentThis object contains the value resulting from the FOM calculation.
1.3.6.1.4.1.4491.2.1.4.1.4.17ScalardsgIfStdDsgSebTunnelTimeoutread-writecurrentThe number of seconds the SEB Server will wait for the SEB Tunnel to be established by the SEBC after receiving the ClientConnect service action.
1.3.6.1.4.1.4491.2.1.4.1.4.18ScalardsgIfStdDsgSebTdsg3Overrideread-writecurrentThis object overrides the value of the Tdsg3 timeout specified in the DCD. A value of -1 indicates that the DCD value will be used. This object is ignored when…
1.3.6.1.4.1.4491.2.1.4.1.4.19TabledsgIfStdDsgSebConnectedDeviceTablenot-accessiblecurrentFor a SEB Server, a list of the connected devices. In general, each SEB Tunnel will be used for multiple devices and will therefore have multiple entries in th…
1.3.6.1.4.1.4491.2.1.4.1.4.19.1RowdsgIfStdDsgSebConnectedDeviceEntrynot-accessiblecurrentThe conceptual row of dsgIfStdDsgSebConnectedDeviceTable.
1.3.6.1.4.1.4491.2.1.4.1.4.19.1.1ColumndsgIfStdDsgSebConnectedDeviceIndexnot-accessiblecurrentThe unique identifier for entries in this table
1.3.6.1.4.1.4491.2.1.4.1.4.19.1.2ColumndsgIfStdDsgSebConnectedDeviceMacAddressread-onlycurrentMAC Address of the connected device.
1.3.6.1.4.1.4491.2.1.4.1.4.19.1.3ColumndsgIfStdDsgSebConnectedDeviceIpAddressTyperead-onlycurrentType of IP Address for dsgIfStdDsgSebConnectedDeviceIpAddress.
1.3.6.1.4.1.4491.2.1.4.1.4.19.1.4ColumndsgIfStdDsgSebConnectedDeviceIpAddressread-onlycurrentGlobal IP address assigned by a DHCP server and used on the DOCSIS network for this device. This object will report 0.0.0.0 if no address has been assigned or …
1.3.6.1.4.1.4491.2.1.4.1.4.19.1.5ColumndsgIfStdDsgSebConnectedDeviceTyperead-onlycurrentType of device. Type cableCard(2) has been deprecated.
1.3.6.1.4.1.4491.2.1.4.1.4.19.1.6ColumndsgIfStdDsgSebTunnelClientIpAddressTyperead-onlycurrentThis object specifies the IP address type of dsgIfStdDsgSebTunnelClientIpAddress.
1.3.6.1.4.1.4491.2.1.4.1.4.19.1.7ColumndsgIfStdDsgSebTunnelClientIpAddressread-onlycurrentThe client side IP address of the SEB Tunnel. If a SEB Tunnel is not established, this object will report 0.0.0.0.
1.3.6.1.4.1.4491.2.1.4.1.4.19.1.8ColumndsgIfStdDsgSebTunnelClientPortread-onlycurrentThe server side TCP port used by this tunnel. If a SEB Tunnel is not established, this object will report 0.
1.3.6.1.4.1.4491.2.1.4.1.4.19.1.9ColumndsgIfStdDsgSebTunnelServerIpAddressTyperead-onlycurrentThis object specifies the IP address type of dsgIfStdDsgSebTunnelServerIpAddress.
1.3.6.1.4.1.4491.2.1.4.1.4.19.1.10ColumndsgIfStdDsgSebTunnelServerIpAddressread-onlycurrentThe server side IP address of the SEB Tunnel. If a SEB Tunnel is not established, this object will report 0.0.0.0.
1.3.6.1.4.1.4491.2.1.4.1.4.19.1.11ColumndsgIfStdDsgSebTunnelServerPortread-onlycurrentThe server side TCP port used by this tunnel. If a SEB Tunnel is not established, this object will report 0.
1.3.6.1.4.1.4491.2.1.4.2NodedsgIfStdConformance
1.3.6.1.4.1.4491.2.1.4.2.1NodedsgIfStdCompliances
1.3.6.1.4.1.4491.2.1.4.2.1.1CompliancedsgIfStdBasicCompliancecurrentThe compliance statement for DOCSIS Set-top Gateway eCMs.
1.3.6.1.4.1.4491.2.1.4.2.1.2CompliancedsgIfStdDsgSebCompliancecurrentThe compliance statement for DOCSIS Set-top Gateway devices that support DSG SEB.
1.3.6.1.4.1.4491.2.1.4.2.1.3CompliancedsgIfStdDeprecatedCompliancedeprecatedThe compliance statement for deprecated objects of the DSGIFSTD MIB.
1.3.6.1.4.1.4491.2.1.4.2.2NodedsgIfStdGroups
1.3.6.1.4.1.4491.2.1.4.2.2.1GroupdsgIfStdConfigGroupcurrentA collection of configuration elements provided in DCD messages and DSG operations.
1.3.6.1.4.1.4491.2.1.4.2.2.2GroupdsgIfStdNotifyGroupcurrentThe collection of DSG notifications that the eCM reports as part of the Set-top device
1.3.6.1.4.1.4491.2.1.4.2.2.3GroupdsgIfStdDsgSebGroupcurrentA collection of configuration elements in support of DSG SEB operation. These objects are required for both clients and servers.
1.3.6.1.4.1.4491.2.1.4.2.2.4GroupdsgIfStdDeprecatedGroupdeprecatedGroup of deprecated objects