MIB Viewer

IPFIX-COLLECTOR-MIB

52 objects
The IPFIX collector MIB defines managed objects that are maintained by the collecting process in traffic collector or IPFIX concentrator. These objects provide informations that are exporter's profile data and received templates. Exporter's profile has that exporter's ip address and port number. In addition, these object has statistics data per session or per templates. Copyright (C) The Internet Society (2005). This version of this MIB module is part of RFC yyyy; see the RFC itself for full legal notices.
Imported Objects
INET-ADDRESS-MIB-- RFC2580 InetAddressType InetAddress
SNMPv2-CONF-- RFC2579 MODULE-COMPLIANCE OBJECT-GROUP
SNMPv2-SMICounter32 Gauge32 Integer32 mib-2 MODULE-IDENTITY OBJECT-TYPE
SNMPv2-TC-- RFC2578 TEXTUAL-CONVENTION DateAndTime RowStatus
OIDNameAccessStatusDescription
1.3.6.1.2.1.999IdentityipfixMIBThe IPFIX collector MIB defines managed objects that are maintained by the collecting process in traffic collector or IPFIX concentrator. These objects provide…
1.3.6.1.2.1.999.1NodeipfixExporter
1.3.6.1.2.1.999.2NodeipfixCollector
1.3.6.1.2.1.999.2.1NodeipfixCollectorObjects
1.3.6.1.2.1.999.2.1.1NodeipfixReceiving
1.3.6.1.2.1.999.2.1.1.1TableipfixExporterTablenot-accessiblecurrentThis table lists Exporters that received by collecting process. This process manages them.
1.3.6.1.2.1.999.2.1.1.1.1RowipfixExporterEntrynot-accessiblecurrentDefines an entry in the ipfixExporterTable
1.3.6.1.2.1.999.2.1.1.1.1.1ColumnipfixExporterIndexnot-accessiblecurrentLocally arbitrary, but unique identifier of an entry in ipfixExporterTable. The value is expected to remain constant from a re-initialization of the entity's n…
1.3.6.1.2.1.999.2.1.1.1.1.2ColumnipfixExporterIpAddressTyperead-onlycurrentThe IP address type of the exporter. The value for IPv4 is ipv4(1). The value for IPv6 is ipv6(2).
1.3.6.1.2.1.999.2.1.1.1.1.3ColumnipfixExporterIpAddressread-onlycurrentThe IP address of the Exporter.
1.3.6.1.2.1.999.2.1.1.1.1.4ColumnipfixLifeTimeTemplateread-onlycurrentThis is the time interval in seconds for the Life Time configured for the template with this session. It is only used to manage the received templates, if this…
1.3.6.1.2.1.999.2.1.1.2TableipfixSessionTablenot-accessiblecurrentThis table lists sessions between exporting process and collecting process. This table has now, or has at some time in the past, established session.
1.3.6.1.2.1.999.2.1.1.2.1RowipfixSessionEntrynot-accessiblecurrentDefines an entry in the ipfixSessionTable
1.3.6.1.2.1.999.2.1.1.2.1.1ColumnipfixSessionIdnot-accessiblecurrentLocally arbitrary, but unique identifier of an entry in ipfixSessionTable. The value is expected to remain constant from a re-initialization of the entity's ne…
1.3.6.1.2.1.999.2.1.1.2.1.2ColumnipfixSessionStatusread-onlycurrentThe status of this session.
1.3.6.1.2.1.999.2.1.1.2.1.3ColumnipfixSessionProtocolread-onlycurrentThe transport protocol is used for receiving sampled packets from the Exporter. The recommended protocols are TCP (6), UDP (17) and SCTP (132). The default is …
1.3.6.1.2.1.999.2.1.1.2.1.4ColumnipfixSessionDstPortread-onlycurrentThe transport protocol port number of exporter which enables exporting process.
1.3.6.1.2.1.999.2.1.1.2.1.5ColumnipfixSessionSrcPortread-onlycurrentThe transport protocol port number of self device which enables collecting Process.
1.3.6.1.2.1.999.2.1.1.3TableipfixSessionStatsTablenot-accessiblecurrentThis table lists sessions statistics between exporting process and collecting process. The collecting process manages them.
1.3.6.1.2.1.999.2.1.1.3.1RowipfixSessionStatsEntrynot-accessiblecurrentDefines an entry in the ipfixSessionStatsTable
1.3.6.1.2.1.999.2.1.1.3.1.3ColumnipfixSessionPacketsread-onlycurrentThe number of packets received from the Exporter through this session.
1.3.6.1.2.1.999.2.1.1.3.1.4ColumnipfixSessionBytesread-onlycurrentThe number of bytes received from the exporter through this session.
1.3.6.1.2.1.999.2.1.1.3.1.5ColumnipfixSessionMessagesread-onlycurrentThe number of IPFIX messages received from the exporter through this session.
1.3.6.1.2.1.999.2.1.1.3.1.6ColumnipfixSessionDiscardMessagesread-onlycurrentThis indicates the number of received IPFIX Message that might be malformed or cant not be encoded.
1.3.6.1.2.1.999.2.1.1.3.1.9ColumnipfixSessionElapsedTimeread-onlycurrentThis timer indicates how long this session has been connected. This elapsed time of the session of IPFIX presents in second.
1.3.6.1.2.1.999.2.1.1.4TableipfixObdomainStatsTablenot-accessiblecurrentThis table lists statistics objects that have data per observation domain.
1.3.6.1.2.1.999.2.1.1.4.1RowipfixObdomainStatsEntrynot-accessiblecurrentDefines an entry in the ipfixObdomainStatsTable.
1.3.6.1.2.1.999.2.1.1.4.1.1ColumnipfixObdomainIdnot-accessiblecurrentIt uses the observation domain id in the received IPFIX message header.
1.3.6.1.2.1.999.2.1.1.4.1.3ColumnipfixObdomainMessagesread-onlycurrentThe number of IPFIX messages received from the Exporter.
1.3.6.1.2.1.999.2.1.1.4.1.4ColumnipfixObdomainFlowsread-onlycurrentThe number of flow records received from the Exporter.
1.3.6.1.2.1.999.2.1.1.4.1.5ColumnipfixObdomainTemplatesread-onlycurrentThe number of templates received from the Exporter.
1.3.6.1.2.1.999.2.1.1.4.1.6ColumnipfixObdomainLatestSeqNumberread-onlycurrentThe latest sequence number. The collecting process overwrites to this object when it receives IPFIX message.
1.3.6.1.2.1.999.2.1.1.4.1.7ColumnipfixObdomainDisorderdSeqNumbersread-onlycurrentThis counter indicates inconformable numbers of sequence number. The collecting process check consistency between received sequence number and received data fl…
1.3.6.1.2.1.999.2.1.1.5TableipfixTemplateTablenot-accessiblecurrentThis table lists templates that are received by the collecting process. This process manages them.
1.3.6.1.2.1.999.2.1.1.5.1RowipfixTemplateEntrynot-accessiblecurrentDefines an entry in the ipfixTemplateTable
1.3.6.1.2.1.999.2.1.1.5.1.1ColumnipfixTemplateIdnot-accessiblecurrentThis number indicates the template id in the IPFIX message.
1.3.6.1.2.1.999.2.1.1.5.1.2ColumnipfixTemplateIndexnot-accessiblecurrentThe ipfixTemplateIndex specifies the order in which the information element ids are used in the template record.
1.3.6.1.2.1.999.2.1.1.5.1.3ColumnipfixTemplateFieldIdread-onlycurrentThis indicates the Information Element Id at position ipfixTemplateIndex in the template ipfixTemplateId. This implicitly gives the data type and state values …
1.3.6.1.2.1.999.2.1.1.5.1.4ColumnipfixTemplateFieldLengthread-onlycurrentThis indicates the length of each Information Element Ids. Especially, in variable length type it is specified as 65535.
1.3.6.1.2.1.999.2.1.1.6TableipfixTemplateStatsTablenot-accessiblecurrentThis table lists statistics objects that have data per template.
1.3.6.1.2.1.999.2.1.1.6.1RowipfixTemplateStatsEntrynot-accessiblecurrentDefines an entry in the ipfixTemplateStatsTable
1.3.6.1.2.1.999.2.1.1.6.1.2ColumnipfixTempFlowsread-onlycurrentThe number of flow records per template received from Exporter.
1.3.6.1.2.1.999.2.1.1.6.1.3ColumnipfixTempReceivedTimeread-onlycurrentTime that the collecting process received this template. The collecting process overwrites to this object when it receives same template.
1.3.6.1.2.1.999.2.2NodeipfixCollectorConformance
1.3.6.1.2.1.999.3NodeipfixPsampExtension
1.3.6.1.2.1.999.4NodeipfixConformance
1.3.6.1.2.1.999.4.1NodeipfixCompliances
1.3.6.1.2.1.999.4.1.1ComplianceipfixCompliancecurrentAn implementation that complies to this module must implement the objects defined in the mandatory groups collectGroupExporters, collectGroupTemplates. The ime…
1.3.6.1.2.1.999.4.2NodeipfixGroups
1.3.6.1.2.1.999.4.2.1GroupipfixGroupExporterscurrentAll objects that are basic for the management function of exporters.
1.3.6.1.2.1.999.4.2.2GroupipfixGroupTemplatescurrentAll objects that are basic for the management function of templates.
1.3.6.1.2.1.999.4.2.3GroupipfixGroupStatisticscurrentAll objects that are basic for the statistics function.