MIB Viewer

JNX-GDOI-MIB

93 objects
Initial version, implements only the GDOI GM notifications and following tables for GDOI protocol. - GDOI Group Table - GDOI Gm Table - GDOI Gm Kek Table - GDOI Gm Tek SelectorTable - GDOI Gm Tek PolicyTable
OIDNameAccessStatusDescription
1.3.6.1.4.1.2636.3.759IdentityjnxGdoiMIBInitial version, implements only the GDOI GM notifications and following tables for GDOI protocol. - GDOI Group Table - GDOI Gm Table - GDOI Gm Kek Table - GDO…
1.3.6.1.4.1.2636.3.759.0NodejnxGdoiMIBNotifications
1.3.6.1.4.1.2636.3.759.0.5NotificationjnxGdoiGmRegistercurrentA notification from a Group Member when it is starting to register with its GDOI Group's Key Server. Registration includes downloading keying & security associ…
1.3.6.1.4.1.2636.3.759.0.6NotificationjnxGdoiGmRegistrationCompletecurrentA notification from a Group Member when it has successfully registered with a Key Server in its GDOI Group. This is equivalent to a Group Member receiving the …
1.3.6.1.4.1.2636.3.759.0.7NotificationjnxGdoiGmReRegistercurrentA notification from a Group Member when it is starting to re-register with a Key Server in its GDOI Group. A Group Member needs to re-register to the key serve…
1.3.6.1.4.1.2636.3.759.0.8NotificationjnxGdoiGmRekeyReceivedcurrentA notification from a Group Member when it has successfully received and processed a rekey from a Key Server in its GDOI Group. Periodically the key server sen…
1.3.6.1.4.1.2636.3.759.0.11NotificationjnxGdoiGmRekeyFailurecurrentAn error notification from a Group Member when it is unable to successfully process and install a rekey (GROUPKEY-PUSH message) sent by the Key Server in its G…
1.3.6.1.4.1.2636.3.759.1NodejnxGdoiMIBObjects
1.3.6.1.4.1.2636.3.759.1.1TablejnxGdoiGroupTablenot-accessiblecurrentA table of information regarding GDOI Groups in use on the network device being queried. This table is modified to include only fields related to Group Member
1.3.6.1.4.1.2636.3.759.1.1.1RowjnxGdoiGroupEntrynot-accessiblecurrentAn entry containing GDOI Group information, uniquely identified by the GDOI Group ID.
1.3.6.1.4.1.2636.3.759.1.1.1.1ColumnjnxGdoiGroupIdTypenot-accessiblecurrentThe Identification Type Value used to parse a GDOI Group ID. The GDOI RFC 3547 defines the types that can be used as a GDOI Group ID, and RFC 4306 defines all …
1.3.6.1.4.1.2636.3.759.1.1.1.2ColumnjnxGdoiGroupIdLengthread-onlycurrentThe length (i.e. number of octets) of a Group ID. If no length is given (i.e. it has a value of 0), the default length of its jnxGdoiGroupIdType should be used…
1.3.6.1.4.1.2636.3.759.1.1.1.3ColumnjnxGdoiGroupIdValuenot-accessiblecurrentThe value of a Group ID with its type indicated by the jnxGdoiGroupIdType. Use the jnxGdoiGroupIdType to parse the Group ID correctly. This Group ID value is s…
1.3.6.1.4.1.2636.3.759.1.1.1.4ColumnjnxGdoiGroupNameread-onlycurrentThe string-readable name configured for or given to a GDOI Group.
1.3.6.1.4.1.2636.3.759.1.2NodejnxGdoiPeers
1.3.6.1.4.1.2636.3.759.1.2.2TablejnxGdoiGmTablenot-accessiblecurrentA table of information regarding GDOI Group Members (GMs) locally configured on the network device being queried. Note that Local Group Members may or may not …
1.3.6.1.4.1.2636.3.759.1.2.2.1RowjnxGdoiGmEntrynot-accessiblecurrentAn entry containing Local GDOI Group Member information, uniquely identified by Group & GM IDs. Because the Group Member is Local to the network device being q…
1.3.6.1.4.1.2636.3.759.1.2.2.1.1ColumnjnxGdoiGmIdTypenot-accessiblecurrentThe Identification Type Value used to parse the identity information for a Initiator or Group Member. RFC 4306 defines all valid types that can be used as an i…
1.3.6.1.4.1.2636.3.759.1.2.2.1.2ColumnjnxGdoiGmIdLengthread-onlycurrentThe length (i.e. number of octets) of a Group Member ID. If no length is given (i.e. it has a value of 0), the default length of its jnxGdoiGmIdType should be …
1.3.6.1.4.1.2636.3.759.1.2.2.1.3ColumnjnxGdoiGmIdValuenot-accessiblecurrentThe value of the identity information for a Group Member with its type indicated by the jnxGdoiGmIdType. Use the jnxGdoiGmIdType to parse the Group Member ID c…
1.3.6.1.4.1.2636.3.759.1.2.2.1.4ColumnjnxGdoiGmRegKeyServerIdTyperead-onlycurrentThe Identification Type Value used to parse the identity information of this Group Member's registered Key Server. RFC 4306 defines all valid types that can be…
1.3.6.1.4.1.2636.3.759.1.2.2.1.5ColumnjnxGdoiGmRegKeyServerIdLengthread-onlycurrentThe length (i.e. number of octets) of the registered Key Server's ID. If no length is given (i.e. it has a value of 0), the default length of its jnxGdoiGmRegK…
1.3.6.1.4.1.2636.3.759.1.2.2.1.6ColumnjnxGdoiGmRegKeyServerIdValueread-onlycurrentThe value of the identity information for this Group Member's registered Key Server with its type indicated by the jnxGdoiGmRegKeyServerIdType. Use the jnxGdoi…
1.3.6.1.4.1.2636.3.759.1.2.2.1.7ColumnjnxGdoiGmActiveKEKread-onlycurrentThe SPI of the Key Encryption Key (KEK) that is currently being used by the Group Member to authenticate & decrypt a rekey from a GROUPKEY-PUSH message.
1.3.6.1.4.1.2636.3.759.1.2.2.1.8ColumnjnxGdoiGmRekeysReceivedread-onlycurrentThe sequence number of the last rekey successfully received from this Group Member's registered Key Server.
1.3.6.1.4.1.2636.3.759.1.2.2.1.9ColumnjnxGdoiGmActiveTEKNumread-onlycurrentThe number of active traffic encryption keys (TEKS) currently being used by the Group Member to encrypt/decrypt/authenticate dataplane traffic.
1.3.6.1.4.1.2636.3.759.1.3NodejnxGdoiSecAssociations
1.3.6.1.4.1.2636.3.759.1.3.2TablejnxGdoiGmKekTablenot-accessiblecurrentA table of information regarding GDOI Key Encryption Key (KEK) Security Associations (SAs) currently installed for GDOI entities acting as Group Members on the…
1.3.6.1.4.1.2636.3.759.1.3.2.1RowjnxGdoiGmKekEntrynot-accessiblecurrentAn entry containing the attributes associated with a GDOI KEK SA, uniquely identified by the Group ID, Group Member (GM) ID, & SPI value assigned by the GM's r…
1.3.6.1.4.1.2636.3.759.1.3.2.1.1ColumnjnxGdoiGmKekIndexnot-accessiblecurrentThe index of the GM KEK in table.The value of the index is a number which begins at one and is incremented with each KEK that is used by the GM for that GDOI g…
1.3.6.1.4.1.2636.3.759.1.3.2.1.2ColumnjnxGdoiGmKekSPIread-onlycurrentThe value of the Security Parameter Index (SPI) of a KEK SA. The SPI must be the ISAKMP Header cookie pair where the first 8 octets become the 'Initiator Cooki…
1.3.6.1.4.1.2636.3.759.1.3.2.1.3ColumnjnxGdoiGmKekSrcIdTyperead-onlycurrentThe Identification Type Value used to parse the identity information for the source of a KEK SA. RFC 4306 defines all valid types that can be used as an identi…
1.3.6.1.4.1.2636.3.759.1.3.2.1.4ColumnjnxGdoiGmKekSrcIdLengthread-onlycurrentThe length (i.e. number of octets) of the source ID of a KEK SA. If no length is given (i.e. it has a value of 0), the default length of its jnxGdoiGmKekSrcIdT…
1.3.6.1.4.1.2636.3.759.1.3.2.1.5ColumnjnxGdoiGmKekSrcIdValueread-onlycurrentThe value of the identity information for the source of a KEK SA with its type indicated by the jnxGdoiGmKekSrcIdType. Use the jnxGdoiGmKekSrcIdType to parse t…
1.3.6.1.4.1.2636.3.759.1.3.2.1.6ColumnjnxGdoiGmKekSrcIdPortread-onlycurrentThe value specifying a port associated with the source ID of a KEK SA. A value of zero means that the port should be ignored. This port value is sent as the `S…
1.3.6.1.4.1.2636.3.759.1.3.2.1.7ColumnjnxGdoiGmKekDstIdTyperead-onlycurrentThe Identification Type Value used to parse the identity information for the dest. (multicast rekey address) of a KEK SA. RFC 4306 defines all valid types that…
1.3.6.1.4.1.2636.3.759.1.3.2.1.8ColumnjnxGdoiGmKekDstIdLengthread-onlycurrentThe length (i.e. number of octets) of the destination ID of a KEK SA. If no length is given (i.e. it has a value of 0), the default length of its jnxGdoiGmKekD…
1.3.6.1.4.1.2636.3.759.1.3.2.1.9ColumnjnxGdoiGmKekDstIdValueread-onlycurrentThe value of the identity information for the destination of a KEK SA (multicast rekey address) with its type indicated by jnxGdoiGmKekDstIdType. Use the jnxGd…
1.3.6.1.4.1.2636.3.759.1.3.2.1.10ColumnjnxGdoiGmKekDstIdPortread-onlycurrentThe value specifying a port associated with the dest. ID of a KEK SA. A value of zero means that the port should be ignored. This port value is sent as the `DS…
1.3.6.1.4.1.2636.3.759.1.3.2.1.11ColumnjnxGdoiGmKekIpProtocolread-onlycurrentThe value of the IP protocol ID (e.g. UDP/TCP) being used for the rekey datagram.
1.3.6.1.4.1.2636.3.759.1.3.2.1.12ColumnjnxGdoiGmKekMgmtAlgread-onlycurrentThe value of the KEK_MANAGEMENT_ALGORITHM which specifies the group KEK management algorithm used to provide forward or backward access control (i.e. used to e…
1.3.6.1.4.1.2636.3.759.1.3.2.1.13ColumnjnxGdoiGmKekEncryptAlgread-onlycurrentThe value of the KEK_ALGORITHM which specifies the encryption algorithm used with the KEK SA. A GDOI implementaiton must support KEK_ALG_3DES. Following are th…
1.3.6.1.4.1.2636.3.759.1.3.2.1.14ColumnjnxGdoiGmKekEncryptKeyLengthread-onlycurrentThe value of the KEK_KEY_LENGTH which specifies the KEK Algorithm key length (in bits).
1.3.6.1.4.1.2636.3.759.1.3.2.1.15ColumnjnxGdoiGmKekSigHashAlgread-onlycurrentThe value of the SIG_HASH_ALGORITHM which specifies the SIG payload hash algorithm. This is not required (i.e. could have a value of zero) if the SIG_ALGORITHM…
1.3.6.1.4.1.2636.3.759.1.3.2.1.16ColumnjnxGdoiGmKekSigAlgread-onlycurrentThe value of the SIG_ALGORITHM which specifies the SIG payload signature algorithm. A GDOI implementation must support SIG_ALG_RSA. Following are the Signature…
1.3.6.1.4.1.2636.3.759.1.3.2.1.17ColumnjnxGdoiGmKekSigKeyLengthread-onlycurrentThe value of the SIG_KEY_LENGTH which specifies the length of the SIG payload key.
1.3.6.1.4.1.2636.3.759.1.3.2.1.18ColumnjnxGdoiGmKekOakleyGroupread-onlycurrentThe value of the KE_OAKLEY_GROUP which specifies the OAKLEY or Diffie-Hellman Group used to compute the PFS secret in the optional KE payload of the GDOI GROUP…
1.3.6.1.4.1.2636.3.759.1.3.2.1.19ColumnjnxGdoiGmKekOriginalLifetimeread-onlycurrentThe value of the KEK_KEY_LIFETIME which specifies the maximum time for which a KEK is valid. The GCKS may refresh the KEK at any time before the end of the val…
1.3.6.1.4.1.2636.3.759.1.3.2.1.20ColumnjnxGdoiGmKekRemainingLifetimeread-onlycurrentThe value of the remaining time for which a KEK is valid. The value is a four (4) octet (32-bit) number which begins at the value of jnxGdoiGmKekOriginalLifeti…
1.3.6.1.4.1.2636.3.759.1.3.2.1.21ColumnjnxGdoiGmKekStatusread-onlycurrentThe status of the KEK SA. When this status value is queried, one of the following is returned: inUse(1), new(2), old(3).
1.3.6.1.4.1.2636.3.759.1.3.5TablejnxGdoiGmTekSelectorTablenot-accessiblecurrentA table of information regarding GDOI Traffic Encryption Key (TEK) Security Associations (SAs/Policies) pushed by a Key Server & installed for GDOI entities ac…
1.3.6.1.4.1.2636.3.759.1.3.5.1RowjnxGdoiGmTekSelectorEntrynot-accessiblecurrentAn entry containing the attributes associated with a GDOI TEK Policy/SA, uniquely identified by the Group ID, Group Member ID, Source/Destination IDs & Ports, …
1.3.6.1.4.1.2636.3.759.1.3.5.1.1ColumnjnxGdoiGmTekSelectorIndexnot-accessiblecurrentThe index of the Source/Destination pair secured by the GM TEK.The value of the index is a number which begins at one and is incremented with each Source/Desti…
1.3.6.1.4.1.2636.3.759.1.3.5.1.2ColumnjnxGdoiGmTekSrcIdTyperead-onlycurrentThe Identification Type Value used to parse the identity information for the source of a TEK Policy/SA. RFC 4306 defines all valid types that can be used as an…
1.3.6.1.4.1.2636.3.759.1.3.5.1.3ColumnjnxGdoiGmTekSrcIdLengthread-onlycurrentThe length (i.e. number of octets) of the source ID of a TEK Policy/SA. If no length is given (i.e. it has a value of 0), the default length of its jnxGdoiGmTe…
1.3.6.1.4.1.2636.3.759.1.3.5.1.4ColumnjnxGdoiGmTekSrcIdValueread-onlycurrentThe value of the identity information for the source of a TEK Policy/SA with its type indicated by the jnxGdoiGmTekSrcIdType. Use the jnxGdoiGmTekSrcIdType to …
1.3.6.1.4.1.2636.3.759.1.3.5.1.5ColumnjnxGdoiGmTekSrcIdPortread-onlycurrentThe value specifying a port associated with the source ID of a TEK Policy/SA. A value of zero means that the port should be ignored. This port value is sent as…
1.3.6.1.4.1.2636.3.759.1.3.5.1.6ColumnjnxGdoiGmTekDstIdTyperead-onlycurrentThe Identification Type Value used to parse the identity information for the dest. of a TEK Policy/SA. RFC 4306 defines all valid types that can be used as an …
1.3.6.1.4.1.2636.3.759.1.3.5.1.7ColumnjnxGdoiGmTekDstIdLengthread-onlycurrentThe length (i.e. number of octets) of the destination ID of a TEK Policy/SA. If no length is given (i.e. it has a value of 0), the default length of its jnxGdo…
1.3.6.1.4.1.2636.3.759.1.3.5.1.8ColumnjnxGdoiGmTekDstIdValueread-onlycurrentThe value of the identity information for the destination of a TEK Policy/SA with its type indicated by the jnxGdoiGmTekDstIdType. Use the jnxGdoiGmTekDstIdTyp…
1.3.6.1.4.1.2636.3.759.1.3.5.1.9ColumnjnxGdoiGmTekDstIdPortread-onlycurrentThe value specifying a port associated with the dest. ID of a TEK Policy/SA. A value of zero means that the port should be ignored. This port value is sent as …
1.3.6.1.4.1.2636.3.759.1.3.5.1.10ColumnjnxGdoiGmTekSecurityProtocolread-onlycurrentThe value of the Protocol-ID field of a SA TEK (SAT) payload which specifies the Security Protocol for a TEK. Following are the Security Protocol values define…
1.3.6.1.4.1.2636.3.759.1.3.5.1.11ColumnjnxGdoiGmTekPolicyMismatchActionread-onlycurrentDefault action for packets that does not match TEK Policy/SA received from group key server
1.3.6.1.4.1.2636.3.759.1.3.6TablejnxGdoiGmTekPolicyTablenot-accessiblecurrentA table of information regarding GDOI Traffic Encryption Key (TEK) Security Associations (SAs/Policies) received by a Key Server & installed for GDOI entities …
1.3.6.1.4.1.2636.3.759.1.3.6.1RowjnxGdoiGmTekPolicyEntrynot-accessiblecurrentAn entry containing the attributes associated with a GDOI TEK Policy/SA, uniquely identified by the Group ID, Group Member ID, TEK Selector (Source/Destination…
1.3.6.1.4.1.2636.3.759.1.3.6.1.1ColumnjnxGdoiGmTekPolicyIndexnot-accessiblecurrentThe index of the SPI used to secure the GM TEK.The value of the index is a number which begins at one and is incremented with each row of the GM TEK SPI table.
1.3.6.1.4.1.2636.3.759.1.3.6.1.2ColumnjnxGdoiGmTekSPIread-onlycurrentThe value of the Security Parameter Index (SPI) of a TEK Policy/SA. The SPI must be the SPI for ESP.
1.3.6.1.4.1.2636.3.759.1.3.6.1.3ColumnjnxGdoiGmTekEncapsulationModeread-onlycurrentThe value of the Encapsulation Mode of a TEK (IPsec SA). Following are the Encapsulation Mode values defined in RFC 2407, however the JnxGdoiEncapsulationMode …
1.3.6.1.4.1.2636.3.759.1.3.6.1.4ColumnjnxGdoiGmTekEncryptionAlgorithmread-onlycurrentThe value of the Transform ID field of a PROTO_IPSEC_ESP payload which specifies the ESP transform to be used. If no encryption is used, this value will be zer…
1.3.6.1.4.1.2636.3.759.1.3.6.1.5ColumnjnxGdoiGmTekEncryptionKeyLengthread-onlycurrentThe length of the key used for encryption in a TEK (in bits).
1.3.6.1.4.1.2636.3.759.1.3.6.1.6ColumnjnxGdoiGmTekIntegrityAlgorithmread-onlycurrentThe value of the Authentication Algorithm for a TEK IPsec ESP SA. If no authentication is used, this value will be zero (0). Following are the Authentication A…
1.3.6.1.4.1.2636.3.759.1.3.6.1.7ColumnjnxGdoiGmTekIntegrityKeyLengthread-onlycurrentThe length of the key used for integrity/authentication in a TEK (in bits).
1.3.6.1.4.1.2636.3.759.1.3.6.1.8ColumnjnxGdoiGmTekWindowSizeread-onlycurrentThe size of the Time Based Anti-Replay (TBAR) window used by this TEK Policy/SA.
1.3.6.1.4.1.2636.3.759.1.3.6.1.9ColumnjnxGdoiGmTekOriginalLifetimeread-onlycurrentThe value of the SA Life Type defined in RFC 2407 which specifies the maximum time for which a TEK IPsec SA is valid. The GCKS may refresh the TEK at any time …
1.3.6.1.4.1.2636.3.759.1.3.6.1.10ColumnjnxGdoiGmTekRemainingLifetimeread-onlycurrentThe value of the remaining time for which a TEK is valid. The value is a four (4) octet (32-bit) number which begins at the value of jnxGdoiGmTekOriginalLifeti…
1.3.6.1.4.1.2636.3.759.1.3.6.1.11ColumnjnxGdoiGmTekStatusread-onlycurrentThe status of the TEK Policy/SA. When this status value is queried, one of the following is returned: inbound(1), outbound(2), biDirectional(3).
Type Definitions
NameSyntaxStatusDescription
JnxGdoiDiffieHellmanGroupINTEGER { dhNone(0), dhGroup1(1), dhGroup2(2), dhEc2nGp155(3), dhEc2nGp185(4), dh1536Modp(5), dh2048Modp(14), dh3072Modp(15), dh4096Modp(16), dh6144Modp(17), dh8192Modp(18), dhEcp256(19), dhEcp84(20), dhEcp521(21), dh1024Modp160(22), dh2048Modp224(23), dh2048Modp256(24), dhEcp192(25), dhEcp224(26) }currentA textual convention indicating the identifier of the Diffie-Hellman Group being used. Following are the possible updated Diffie-Hellman Group values & JnxGdoiDiffieHellmanGroup mappings after RFC 4306: Diffie-Hellman G…
JnxGdoiEncapsulationModeINTEGER { encapUnknown(0), encapTunnel(1), encapTransport(2), encapUdpTunnel(3), encapUdpTransport(4) }currentA textual convention indicating the identifier of the Encapsulation Mode being used. Following are the possible Encapsulation Mode values & JnxGdoiEncapsulationMode mappings from RFC 2407: Encapsulation Mode Value Tunne…
JnxGdoiEncryptionAlgorithmINTEGER { encrAlgNone(0), encrAlgDes64(1), encrAlgDes(2), encrAlg3Des(3), encrAlgRc5(4), encrAlgIdea(5), encrAlgCast(6), encrAlgBlowfish(7), encrAlg3Idea(8), encrAlgDes32(9), encrAlgRc4(10), encrAlgNull(11), encrAlgAesCbc(12), encrAlgAesCtr(13), encrAlgAesCcm8(14), encrAlgAesCcm12(15), encrAlgAesCcm16(16), encrAlgAesGcm8(18), encrAlgAesGcm12(19), encrAlgAesGcm16(20), encrAlgNullAuthAesGmac(21), encrAlgCamelliaCbc(23), encrAlgCamelliaCtr(24), encrAlgCamelliaCcm8(25), encrAlgCamelliaCcm12(26), encrAlgCamelliaCcm1(27), encrAlgSeedCbc(28) }currentA textual convention indicating the identifier of the encryption algorithm being used. Following are the possible updated encryption algorithm values & JnxGdoiEncryptionAlgorithm mappings after RFC 4306: Encryption Algo…
JnxGdoiIdentificationTypeINTEGER { ipv4Address(1), domainName(2), userName(3), ipv4Subnet(4), ipv6Address(5), ipv6Subnet(6), ipv4Range(7), ipv6Range(8), caDistinguishedName(9), caGeneralName(10), groupNumber(11) }currentA textual convention indicating the type of value used to identify a GDOI entity (i.e. Group, Key Server, or Group Member). Following are the Identification Type Values: ID Type Value RESERVED 0 ID_IPV4_ADDR 1 ID_FQDN 2…
JnxGdoiIdentificationValueOCTET STRING (SIZE (0..48))currentA textual convention indicating the actual value of used to identify a GDOI entity (i.e. Group, Key Server, or Group Member). The value of the JnxGdoiIdentificationValue object can be parsed based on the value of the as…
JnxGdoiIntegrityAlgorithmINTEGER { authAlgNone(0), authAlgMd5Hmac96(1), authAlgSha1Hmac96(2), authAlgDesMac(3), authAlgMd5Kpdk(4), authAlgAesXcbc96(5), authAlgMd5Hmac128(6), authAlgSha1Hmac160(7), authAlgAesCmac96(8), authAlgAes128Gmac(9), authAlgAes192Gmac(10), authAlgAes256Gmac(11), authAlgSha2Hmac256to128(12), authAlgSha2Hmac384to192(13), authAlgSha2Hmac512to256(14) }currentA textual convention indicating the identifier of the integirty algorithm being used. Following are the possible updated integrity algorithm values & JnxGdoiIntegrityAlgorithm mappings after RFC 4306: Integrity Algorith…
JnxGdoiIpProtocolIdINTEGER { ipProtocolUnknown(0), ipProtocolTCP(1), ipProtocolUDP(2) }currentA textual convention indicating the identifier of the IP Protocol being used for the rekey datagram. Some possible values are: ID Value ID Type 06 TCP 17 UDP REFERENCE
JnxGdoiKekSPIOCTET STRING (SIZE (16))currentA textual convention indicating a SPI (Security Parameter Index) of sixteen (16) octets for a KEK. The SPI must be the ISAKMP Header cookie pair where the first 8 octets become the 'Initiator Cookie' field of the GROUPK…
JnxGdoiKekStatusINTEGER { inUse(1), new(2), old(3) }currentA textual convention indicating the status of a GDOI KEK and its corresponding Security Association (SA). 'inUse' : KEK currently being used to encrypt new KEK/TEKs 'new' : KEK currently being sent to all peers 'old' : …
JnxGdoiKeyManagementAlgorithmINTEGER { keyMgmtNone(0), keyMgmtLkh(1) }currentA textual convention indicating the identifier of the key/KEK management algorithm being used to provide forward or backward access control (i.e. used to exclude group members). Following are the possible KEK management…
JnxGdoiPolicyMismatchActionINTEGER { drop(1), forward(2), unknown(3) }currentA textual convention indicating the default action for packets that does not match TEK policy/SA. 'drop' : Drop packets that do not match the TEK policy/SA. 'forward': Forward the packets as received that do not match t…
JnxGdoiPseudoRandomFunctionINTEGER { prfNone(0), prfMd5Hmac(1), prfSha1Hmac(2), prfTigerHmac(3), prfAes128Xcbc(4), prfSha2Hmac256(5), prfSha2Hmac384(6), prfSha2Hmac512(7), prfAes128Cmac(8) }currentA textual convention indicating the identifier of the pseudo-random function (PRF) being used. Following are the possible updated PRF values & JnxGdoiPseudoRandomFunction mappings after RFC 4306: Pseudo-Random Function …
JnxGdoiSecurityProtocolINTEGER { secProtocolUnknown(0), secProtocolIpsecEsp(1) }currentA textual convention indicating the identifier of the Security Protocol being used. Following are the possible Security Protocol ID values & JnxGdoiSecurityProtocol mappings from the GDOI RFC 3547: Security Protocol ID …
JnxGdoiSignatureMethodINTEGER { sigNone(0), sigRsa(1), sigSharedKey(2), sigDss(3), sigEncryptRsa(4), sigRevEncryptRsa(5), sigEcdsa256(9), sigEcdsa384(10), sigEcdsa512(11) }currentA textual convention indicating the identifier of the integirty algorithm being used. Following are the possible updated authentication method values & JnxGdoiSignatureMethod mappings after RFC 4306: Authentication Meth…
JnxGdoiTekSPIOCTET STRING (SIZE (4))currentA textual convention indicating a SPI (Security Parameter Index) of four (4) octets for a TEK using ESP.
JnxGdoiTekStatusINTEGER { inbound(1), outbound(2), biDirectional(3) }currentA textual convention indicating the status of a GDOI TEK and its corresponding Security Association (SA). 'inbound' : TEK is being used as inbound (receive) SA 'outbound' : TEK is being used as outbound (transmit) SA 'b…
JnxGdoiUnsigned16OCTET STRING (SIZE (2))currentA textual convention indicating a 16-bit unsigned integer value.