MIDCOM-SERVER-MIB
48 objects
This MIB module defines a set of basic objects for monitoring and configuring MIDCOM servers on middleboxes that support MIDCOM. Such middleboxes may be firewalls and network address translators. This MIB module does not implement portions of the MIDCOM protocol, but is the MIDCOM SERVER MIB module for monitoring instances of the MIDCOM protocol. There are three groups of managed objects defined by this MIB module: - objects describing the used middlebox resources on a per MIDCOM policy rule base - objects describing the used firewall configuration on a per MIDCOM policy rule base - objects providing statistical information about the MIDCOM MIB module Copyright (C) The Internet Society (2003). This version of this MIB module is part of RFC yyyy; see the RFC itself for full legal notices.
Imported Objects
| IF-MIB | -- RFC3411 InterfaceIndex |
| MIDCOM-MIB | -- RFC2863 midcomSessionOwner midcomGroupIndex midcomRuleIndex |
| SNMP-FRAMEWORK-MIB | -- RFC2580 SnmpAdminString |
| SNMPv2-CONF | -- RFC2579 MODULE-COMPLIANCE OBJECT-GROUP |
| SNMPv2-SMI | mib-2 MODULE-IDENTITY OBJECT-TYPE Unsigned32 |
| SNMPv2-TC | -- RFC2578 TEXTUAL-CONVENTION |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.2.1.44445 | IdentitymidcomSrvMIB | This MIB module defines a set of basic objects for monitoring and configuring MIDCOM servers on middleboxes that support MIDCOM. Such middleboxes may be firewa… | ||
| 1.3.6.1.2.1.44445.1 | NodemidcomSrvObjects | |||
| 1.3.6.1.2.1.44445.1.1 | NodemidcomSrvResources | |||
| 1.3.6.1.2.1.44445.1.1.1 | TablemidcomSrvResourceTable | not-accessible | current | This table lists all used middlebox resources per MIDCOM policy rule. The midcomSrvMBTable is indexed by session owner, group index, rule index. |
| 1.3.6.1.2.1.44445.1.1.1.1 | RowmidcomSrvResourceEntry | not-accessible | current | An entry describing a particular set of middlebox resources. |
| 1.3.6.1.2.1.44445.1.1.1.1.4 | ColumnnatSrcBindMode | read-only | current | An indication whether this policy rule uses an address NAT bind or an address-port NAT bind for the source address. |
| 1.3.6.1.2.1.44445.1.1.1.1.5 | ColumnnatSrcBindId | read-only | current | The allocated NAT bind for the source address used by this policy rule. |
| 1.3.6.1.2.1.44445.1.1.1.1.6 | ColumnnatDstBindMode | read-only | current | An indication whether this policy rule uses an address NAT bind or an address-port NAT bind for the destination address. |
| 1.3.6.1.2.1.44445.1.1.1.1.7 | ColumnnatDstBindId | read-only | current | The allocated NAT bind for the destination address used by this policy rule. |
| 1.3.6.1.2.1.44445.1.1.1.1.8 | ColumnnatSessionId1 | read-only | current | A unique ID that is assigned to this specific NAT session at the NAT for this policy rule. A maximum of two NAT sessions can be assigned to one policy rule. |
| 1.3.6.1.2.1.44445.1.1.1.1.9 | ColumnnatSessionId2 | read-only | current | A unique ID that is assigned to this specific NAT session at the NAT for this policy rule. A maximum of two NAT sessions can be assigned to one policy rule. |
| 1.3.6.1.2.1.44445.1.1.1.1.10 | ColumnfwRuleId | read-only | current | A unique ID that is assigned to this specific firewall rule at the firewall for this policy rule. |
| 1.3.6.1.2.1.44445.1.1.2 | TablemidcomSrvFwTable | not-accessible | current | This table lists the firewal configuration per interface. The midcomSrvFwTable is indexed by midcomifIndex |
| 1.3.6.1.2.1.44445.1.1.2.1 | RowmidcomSrvFwEntry | not-accessible | current | An entry describing a particular set of firewall resources. |
| 1.3.6.1.2.1.44445.1.1.2.1.1 | ColumnmidcomifIndex | not-accessible | current | The corresponding interface of the middlebox. |
| 1.3.6.1.2.1.44445.1.1.2.1.2 | ColumnfwGroup | read-write | current | The firewall rule group to which all firewall rules of the MIDCOM server are assigned. |
| 1.3.6.1.2.1.44445.1.1.2.1.3 | ColumnfwPriority | read-write | current | The priority assigned to all firewall rules of the MIDCOM server. |
| 1.3.6.1.2.1.44445.1.2 | NodemidcomSrvStatistics | |||
| 1.3.6.1.2.1.44445.1.2.1 | ScalarmidcomSrvSessionsRejected | read-only | current | The number of rejected MIDCOM sessions. The MIDCOM MIB module can rejected sessions that are not authorized or unknown. |
| 1.3.6.1.2.1.44445.1.2.2 | ScalarmidcomSrvSessionsCurrent | read-only | current | The number of currently established MIDCOM sessions. This object equals the number of rows in the midcomSessionTable and gives the number of MIDCOM agents (=SN… |
| 1.3.6.1.2.1.44445.1.2.3 | ScalarmidcomSrvSessionsTotal | read-only | current | The summarized number of all current and past established MIDCOM sessions. |
| 1.3.6.1.2.1.44445.1.2.4 | ScalarmidcomSrvRuleEntriesRejected | read-only | current | The number of policy rule entries rejected without any further detailed reason. Policy rules may be rejected due to several reasons. This object counts policy … |
| 1.3.6.1.2.1.44445.1.2.5 | ScalarmidcomSrvRulesIncomplete | read-only | current | The total number of policy rules that are incomplete. Policy rules are loaded via row entries in midcomRuleTable. This object counts policy rules that are load… |
| 1.3.6.1.2.1.44445.1.2.6 | ScalarmidcomSrvResRulesRejected | read-only | current | The total number of reserved policy rules that are loaded, but are rejected. |
| 1.3.6.1.2.1.44445.1.2.7 | ScalarmidcomSrvResRulesFailed | read-only | current | The total number of failed reserved policy rules. |
| 1.3.6.1.2.1.44445.1.2.8 | ScalarmidcomSrvResRulesActive | read-only | current | The number of currently active reserved policy rules. |
| 1.3.6.1.2.1.44445.1.2.9 | ScalarmidcomSrvResRulesExpired | read-only | current | The number of currently expired reserved policy rules. |
| 1.3.6.1.2.1.44445.1.2.10 | ScalarmidcomSrvResRulesTerminated | read-only | current | The number of currently terminated reserved policy rules. |
| 1.3.6.1.2.1.44445.1.2.11 | ScalarmidcomSrvResRulesOnRequest | read-only | current | The number of currently on-request reserved policy rules. |
| 1.3.6.1.2.1.44445.1.2.12 | ScalarmidcomSrvEnabledRulesRejected | read-only | current | The total number of rejected enabled policy rules. |
| 1.3.6.1.2.1.44445.1.2.13 | ScalarmidcomSrvEnabledRulesFailed | read-only | current | The total number of failed enabled policy rules. |
| 1.3.6.1.2.1.44445.1.2.14 | ScalarmidcomSrvEnabledRulesActive | read-only | current | The number of currently active enabled policy rules. |
| 1.3.6.1.2.1.44445.1.2.15 | ScalarmidcomSrvEnabledRulesExpired | read-only | current | The number of currently expired enabled policy rules. |
| 1.3.6.1.2.1.44445.1.2.16 | ScalarmidcomSrvEnabledRulesTerminated | read-only | current | The number of currently terminated enabled policy rules. |
| 1.3.6.1.2.1.44445.1.2.17 | ScalarmidcomSrvEnabledRulesOnRequest | read-only | current | The number of currently on-request enabled policy rules. |
| 1.3.6.1.2.1.44445.1.2.18 | ScalarmidcomSrvTransRejected | read-only | current | The total number of rejected transactions. |
| 1.3.6.1.2.1.44445.1.2.19 | ScalarmidcomSrvTransFailed | read-only | current | The total number of failed transactions. |
| 1.3.6.1.2.1.44445.1.2.20 | ScalarmidcomSrvTransCompleted | read-only | current | The total number of completed transactions. |
| 1.3.6.1.2.1.44445.2 | NodemidcomSrvConformance | |||
| 1.3.6.1.2.1.44445.2.1 | NodemidcomSrvCompliances | |||
| 1.3.6.1.2.1.44445.2.1.1 | CompliancemidcomSrvCompliance | current | The compliance statement for SNMP entities that implement the MIDCOM SERVER MIB. | |
| 1.3.6.1.2.1.44445.2.2 | NodemidcomSrvGroups | |||
| 1.3.6.1.2.1.44445.2.2.1 | GroupmidcomSrvResourceGroup | current | A collection of objects providing information about the used NAT resources. | |
| 1.3.6.1.2.1.44445.2.2.2 | GroupmidcomSrvFwGroup | current | A collection of objects providing information about the used firewall resources. | |
| 1.3.6.1.2.1.44445.2.2.3 | GroupmidcomSrvStatisticsGroup | current | A collection of objects providing statistical information about the MIDCOM server. |
Type Definitions
| Name | Syntax | Status | Description |
|---|---|---|---|
| MidcomNatBindId | Unsigned32 | current | A unique ID that is assigned to each NAT bind by a NAT enabled device. |
| MidcomNatBindMode | INTEGER { addressBind (1), addressPortBind (2) } | current | An indication whether the NAT bind is an address bind or an address-port bind. |
| MidcomNatSessionId | Unsigned32 | current | A unique ID that is assigned to each NAT session by a NAT enabled device. |