Npi-NuSwitch-COMMON-MIB
75 objects
No module-level DESCRIPTION found.
Imported Objects
| RFC-1212 | OBJECT-TYPE |
| RFC-1215 | TRAP-TYPE |
| RFC1155-SMI | Counter Gauge IpAddress mgmt NetworkAddress TimeTicks |
| RFC1213-MIB | DisplayString |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.1 | Nodedirectory | |||
| 1.3.6.1.2 | Nodemgmt | |||
| 1.3.6.1.3 | Nodeexperimental | |||
| 1.3.6.1.4 | Nodeprivate | |||
| 1.3.6.1.4.1 | Nodeenterprises | |||
| 1.3.6.1.4.1.1101 | Nodenpi | |||
| 1.3.6.1.4.1.1101.2 | Nodenpi-Switching-MIB | |||
| 1.3.6.1.4.1.1101.2.13 | Nodeswitch-DS24 | |||
| 1.3.6.1.4.1.1101.2.13.1 | NodeswitchBasicHubInfo | |||
| 1.3.6.1.4.1.1101.2.13.1.1 | ScalarswitchHubMibVersion | read-only | mandatory | MIB version, 1 1 1 10000 -> 0.00.60 |
| 1.3.6.1.4.1.1101.2.13.1.2 | ScalarswitchHubHwAgingSwitch | read-write | mandatory | Enable the HW aging or not. If enabled the default Aging will be 300 secs |
| 1.3.6.1.4.1.1101.2.13.1.4 | ScalarswitchHubLed | read-only | mandatory | The object indicates Hub's LED current status. |
| 1.3.6.1.4.1.1101.2.13.1.5 | ScalarswitchAddrSpanningTreefunction | read-only | mandatory | The object indicates that the spanning tree function supports or not. |
| 1.3.6.1.4.1.1101.2.13.1.6 | ScalarswitchAddrSecurityfunction | read-only | mandatory | The object indicates the security function supports or not. |
| 1.3.6.1.4.1.1101.2.13.1.7 | ScalarbasicSwitchPortMonitoringfunction | read-only | mandatory | The object indicates the port monitor function supports or not. |
| 1.3.6.1.4.1.1101.2.13.1.8 | ScalarbasicSwitchVirtualLANfunction | read-only | mandatory | The object indicates the Virtual LAN function supports or not. |
| 1.3.6.1.4.1.1101.2.13.1.11 | ScalarbasicSwitchHubClearStats | read-write | mandatory | Clear switching hub's counters: 1. Bridge MIB (1.3.6.1.2.1.17.) dot1dStpTopChange (.2.4.0) 2. Repeater MIB (1.3.6.1.2.1.22.) !!! Only clear switching hub (unit… |
| 1.3.6.1.4.1.1101.2.13.1.12 | ScalarbasicSwitchRMONMIBfunction | read-only | mandatory | The object indicates the RMON MIB function supports or not. |
| 1.3.6.1.4.1.1101.2.13.2 | NodeswitchBasicPortInfo | |||
| 1.3.6.1.4.1.1101.2.13.2.1 | TableswitchPortTable | not-accessible | mandatory | Basic information for each port. |
| 1.3.6.1.4.1.1101.2.13.2.1.1 | RowswitchPortEntry | not-accessible | mandatory | Port information entry. |
| 1.3.6.1.4.1.1101.2.13.2.1.1.1 | ColumnswitchPortIndex | read-only | mandatory | port number : DS24 : ( 1 .. 24) FE-1200 : ( 1 .. 12) FE210 : ( 1 .. 12) FE224: ( 1 .. 6) |
| 1.3.6.1.4.1.1101.2.13.2.1.1.3 | ColumnswitchPortType | read-only | mandatory | The type of each port. |
| 1.3.6.1.4.1.1101.2.13.2.1.1.4 | ColumnswitchPortLink | read-only | mandatory | This object indicates the link status of each port is up or down. |
| 1.3.6.1.4.1.1101.2.13.2.1.1.5 | ColumnswitchPortEnable | read-write | mandatory | Enable/disable status of the port, default = enable(1). |
| 1.3.6.1.4.1.1101.2.13.2.1.1.6 | ColumnswitchPortFullDuplex | read-write | mandatory | Full/half duplex, default = disable(2), Conditional Write: this object can be written only when switchPortAutoNegotiation is disable and port is enabled. |
| 1.3.6.1.4.1.1101.2.13.2.1.1.8 | ColumnswitchPortVirtualLanModeStatus | read-only | mandatory | The object indicates whether the port is in Virtual LAN mode. |
| 1.3.6.1.4.1.1101.2.13.2.1.1.9 | ColumnswitchPortSpeed | read-write | mandatory | Port data rate, this object can be writen only when switchPortAutoNegotiation is set disable . |
| 1.3.6.1.4.1.1101.2.13.2.1.1.10 | ColumnswitchPortAutoNegotiationFunction | read-only | mandatory | The object indicates that the auto-negotiation function of the port supports or not, default = support(1). |
| 1.3.6.1.4.1.1101.2.13.2.1.1.11 | ColumnswitchPortAutoNegotiation | read-write | mandatory | Enable/disable the function of the port auto-negotiation, default = enable (1). |
| 1.3.6.1.4.1.1101.2.13.7 | NodeswitchPortMonitorInfo | |||
| 1.3.6.1.4.1.1101.2.13.7.1 | ScalarswitchPortMonitorswitch | read-write | mandatory | A state to present whether the port monitor function is ON or OF in the hub. The default is OFF. |
| 1.3.6.1.4.1.1101.2.13.7.2 | ScalarswitchPortMonitorMaxCount | read-only | mandatory | Max. monitor count in this hub DS24 = 23 |
| 1.3.6.1.4.1.1101.2.13.7.3 | ScalarswitchPortMonitorActiveCount | read-only | mandatory | Current active monitor count in this hub. |
| 1.3.6.1.4.1.1101.2.13.7.4 | ScalarswitchPortMonitoringOperation | read-write | mandatory | Operation information. |
| 1.3.6.1.4.1.1101.2.13.7.5 | ScalarswitchPortMonitorMessageStatus | read-only | mandatory | The new operation message. |
| 1.3.6.1.4.1.1101.2.13.8 | NodeswitchVirtualLanInfo | |||
| 1.3.6.1.4.1.1101.2.13.8.1 | ScalarswitchVirtualLanSwitch | read-write | mandatory | A state to present whether the virtul LAN function is ON or OFF in the hub. To OFF the switch must write by the original manager. The default value is OFF. |
| 1.3.6.1.4.1.1101.2.13.8.2 | ScalarswitchVirtualLanOperation | read-write | mandatory | Operation information for Virtual LAN. |
| 1.3.6.1.4.1.1101.2.13.8.5 | ScalarswitchVirtualLanMessage | read-only | mandatory | the operation message. |
| 1.3.6.1.4.1.1101.2.13.10 | NodeswitchStatisticInfo | |||
| 1.3.6.1.4.1.1101.2.13.10.1 | TableswitchStatisticPortTable | not-accessible | mandatory | A table that contains information about every port that is associated with this transparent bridge. |
| 1.3.6.1.4.1.1101.2.13.10.1.1 | RowswitchStatisticPortEntry | not-accessible | mandatory | A list of information for each port of a transparent bridge. |
| 1.3.6.1.4.1.1101.2.13.10.1.1.1 | ColumnswitchStatisticPort | read-only | mandatory | The port number of the port for which this entry contains Transparent bridging management information. FE-1200 : ( 1 .. 12) FE-210 : ( 1 .. 12) FE-224 : ( 1 ..… |
| 1.3.6.1.4.1.1101.2.13.10.1.1.2 | ColumnswitchStatisticPortInFrames | read-only | mandatory | The number of frames that have been received by this port from its segment. Note that a frame received on the interface corresponding to this port is only coun… |
| 1.3.6.1.4.1.1101.2.13.10.1.1.3 | ColumnswitchStatisticPortOutFrames | read-only | mandatory | The number of frames that have been transmitted by this port to its segment. Note that a frame transmitted on the interface corresponding to this port is only … |
| 1.3.6.1.4.1.1101.2.13.10.1.1.4 | ColumnswitchStatisticPortInDiscards | read-only | mandatory | Count of valid frames received which were discarded (i.e., filtered) by the Forwarding Process. |
| 1.3.6.1.4.1.1101.2.13.10.1.1.5 | ColumnswitchStatisticPortInKBytes | read-only | mandatory | The number of k-bytes of switchStatisticPortInFrame |
| 1.3.6.1.4.1.1101.2.13.10.1.1.6 | ColumnswitchStatisticPortOutKBytes | read-only | mandatory | The number of k-bytes of switchStatisticPortOutFrame |
| 1.3.6.1.4.1.1101.2.13.10.1.1.7 | ColumnswitchStatisticPortRxFCSError | read-only | mandatory | The number of received FCS error packet count |
| 1.3.6.1.4.1.1101.2.13.10.1.1.8 | ColumnswitchStatisticPortRxAllignError | read-only | mandatory | The number of received allignment error packet count |
| 1.3.6.1.4.1.1101.2.13.10.1.1.9 | ColumnswitchStatisticPortRxRUNTError | read-only | mandatory | The number of received RUNT error packet count |
| 1.3.6.1.4.1.1101.2.13.10.1.1.10 | ColumnswitchStatisticPortRxFrameLongError | read-only | mandatory | The number of received farme too long error packet count |
| 1.3.6.1.4.1.1101.2.13.10.1.1.11 | ColumnswitchStatisticPortOutDiscards | read-only | mandatory | Count of valid frames received which were discarded (i.e., filtered) by the outgoing Forwarding Process. |
| 1.3.6.1.4.1.1101.2.13.10.1.1.12 | ColumnswitchStatisticPortNetCollision | read-only | mandatory | The number of nework collision count |
| 1.3.6.1.4.1.1101.2.13.10.1.1.13 | ColumnswitchStatisticPortHashCollision | read-only | mandatory | The number of forward collision count |
| 1.3.6.1.4.1.1101.2.13.10.1.1.14 | ColumnswitchStatisticPortLossPacket | read-only | mandatory | The number of loss packets after the input buffer full |
| 1.3.6.1.4.1.1101.2.13.11 | NodeswitchMonUnitInfo | |||
| 1.3.6.1.4.1.1101.2.13.11.1 | ScalarswitchmonUnitCollision | read-only | mandatory | 11 1 |
| 1.3.6.1.4.1.1101.2.13.14 | NodeswitchSpanningTreeInfo | |||
| 1.3.6.1.4.1.1101.2.13.14.1 | ScalarswitchSpanningTreeSwitch | read-write | mandatory | A switch to select whether the spanning tree is ON or OFF. The default is ON. If the value is changed, the system need to be restarted. |
| 1.3.6.1.4.1.1101.2.13.15 | TableswitchSnmpManagerTable | not-accessible | mandatory | This table contains the information needed for SNMP Management. |
| 1.3.6.1.4.1.1101.2.13.15.1 | RowswitchSnmpManagerEntry | not-accessible | mandatory | |
| 1.3.6.1.4.1.1101.2.13.15.1.1 | ColumnswitchSnmpManagerIndex | read-only | mandatory | |
| 1.3.6.1.4.1.1101.2.13.15.1.2 | ColumnswitchSnmpManagerHostname | read-write | mandatory | The host name of the management station which has the SNMP access . |
| 1.3.6.1.4.1.1101.2.13.15.1.3 | ColumnswitchSnmpManagerIpAddr | read-write | mandatory | The Internet address of the management station which has the SNMP access . |
| 1.3.6.1.4.1.1101.2.13.15.1.4 | ColumnswitchSnmpManagerComm | read-write | mandatory | Community name used for SNMP management for this station |
| 1.3.6.1.4.1.1101.2.13.16 | TableswitchCommManagerTable | not-accessible | mandatory | This table contains the information needed for access permissions for community |
| 1.3.6.1.4.1.1101.2.13.16.1 | RowswitchCommManagerEntry | not-accessible | mandatory | |
| 1.3.6.1.4.1.1101.2.13.16.1.1 | ColumnswitchCommManagerIndex | read-only | mandatory | |
| 1.3.6.1.4.1.1101.2.13.16.1.2 | ColumnswitchCommManagerComm | read-write | mandatory | Community name used for SNMP management for this station |
| 1.3.6.1.4.1.1101.2.13.16.1.3 | ColumnswitchCommManagerGet | read-write | mandatory | The object indicates whether this comminuty has SNMP Get access or not. |
| 1.3.6.1.4.1.1101.2.13.16.1.4 | ColumnswitchCommManagerSet | read-write | mandatory | The object indicates whether this comminuty has SNMP Set access or not. |
| 1.3.6.1.4.1.1101.2.13.16.1.5 | ColumnswitchCommManagerTrap | read-write | mandatory | The object indicates whether trap is set to this comminuty or not. |
Type Definitions
| Name | Syntax | Status | Description |
|---|---|---|---|
| MacAddress | OCTET STRING (SIZE (6)) |