MIB Viewer

SERVICE-LOCATION-PROTOCOL-MIB

44 objects
The MIB module for monitoring (but not configuration) of SLP (Service Location Protocol) directory agents (DAs), service agents (SAs), and/or user agents (UAs) on managed systems.
Imported Objects
SNMP-FRAMEWORK-MIB-- IETF RFC 2580 SnmpAdminString
SNMPv2-CONF-- IETF RFC 2579 MODULE-COMPLIANCE OBJECT-GROUP
SNMPv2-SMIInteger32 mib-2 MODULE-IDENTITY OBJECT-TYPE
SNMPv2-TC-- IETF RFC 2578 TEXTUAL-CONVENTION TruthValue
OIDNameAccessStatusDescription
1.3.6.1.2.1.999IdentityslpMIBThe MIB module for monitoring (but not configuration) of SLP (Service Location Protocol) directory agents (DAs), service agents (SAs), and/or user agents (UAs)…
1.3.6.1.2.1.999.1NodeslpMIBObjects
1.3.6.1.2.1.999.1.1NodeslpAgent
1.3.6.1.2.1.999.1.1.1TableslpAgentTablenot-accessiblecurrentA table containing SLP (Service Location Protocol) objects for all of the SLP directory agents (DAs), service agents (SAs), or user agents (UAs) currently inst…
1.3.6.1.2.1.999.1.1.1.1RowslpAgentEntrynot-accessiblecurrentAn entry containing SLP (Service Location Protocol) objects for one of the SLP directory agents (DAs), service agents (SAs), or user agents (UAs) currently ins…
1.3.6.1.2.1.999.1.1.1.1.1ColumnslpAgentIndexnot-accessiblecurrentOrdinal of this conceptual row in 'slpAgentTable'.
1.3.6.1.2.1.999.1.1.1.1.2ColumnslpAgentSWInstalledIndexOrZeroread-onlycurrentThe value of 'hrSWInstalledIndex' in the Host Resources MIB (RFC 2790) for the executable software for this SLP agent, or zero if none. See: 'hrSWInstalledInde…
1.3.6.1.2.1.999.1.1.1.1.3ColumnslpAgentNameread-onlycurrentThe friendly locally unique name for this SLP agent, for use with remote network management scripts and GUIs For example 'daNewYork'.
1.3.6.1.2.1.999.1.1.1.1.4ColumnslpAgentTyperead-onlycurrentThe type of this SLP agent (DA, SA, or UA). See: 'net.slp.isDA' in SLP API (RFC 2614).
1.3.6.1.2.1.999.1.1.1.1.5ColumnslpAgentIsBroadcastOnlyread-onlycurrentBroadcast only network enabled for this SLP agent. If 'true', SLP agent MUST send only broadcast messages. If 'false', SLP agent MAY send multicast messages. S…
1.3.6.1.2.1.999.1.1.1.1.6ColumnslpAgentActiveDADiscoveryread-onlycurrentActive DA discovery allowed for this SLP agent. If 'true', SLP agent MAY actively discover DAs, If 'false', SLP agent MUST NOT actively discover DAs. See: 'Act…
1.3.6.1.2.1.999.1.1.1.1.7ColumnslpAgentPassiveDADiscoveryread-onlycurrentPassive DA discovery allowed for this SLP agent. If 'true', SLP agent MAY passively discover DAs, If 'false', SLP agent MUST NOT passively discover DAs. See: '…
1.3.6.1.2.1.999.1.1.1.1.8ColumnslpAgentMessageTypesSupportedread-onlycurrentThe SLP message types supported by this SLP agent, expressed as an array of binary Function-ID values (RFC 2608). For example '0102'H means 'SrvRqst, SrvRply'.…
1.3.6.1.2.1.999.1.1.1.1.9ColumnslpAgentExtensionsSupportedread-onlycurrentThe SLP extensions supported by this SLP agent, expressed as an array of binary Extension ID values (RFC 2608), in network byte order (i.e., big-endian represe…
1.3.6.1.2.1.999.1.2NodeslpScope
1.3.6.1.2.1.999.1.2.1TableslpScopeTablenot-accessiblecurrentA table containing SLP (Service Location Protocol) objects for scope lists on this managed system. Usage: This table sparsely augments the 'slpAgentTable'. Usa…
1.3.6.1.2.1.999.1.2.1.1RowslpScopeEntrynot-accessiblecurrentAn entry containing SLP (Service Location Protocol) objects for one scope value on this managed system.
1.3.6.1.2.1.999.1.2.1.1.1ColumnslpScopeIndexnot-accessiblecurrentOrdinal of this conceptual single row in 'slpScopeTable', subordinate to 'slpAgentIndex'.
1.3.6.1.2.1.999.1.2.1.1.2ColumnslpScopeSourceread-onlycurrentThe source (DHCP, etc) of this SLP scope. See: Section 2 'Introduction' in RFC 2610.
1.3.6.1.2.1.999.1.2.1.1.3ColumnslpScopeValueread-onlycurrentOne scope configured or discovered for this SLP agent. Note: The default (and lowest preference) scope value for any SLP agent is the string 'DEFAULT' verbatim…
1.3.6.1.2.1.999.1.3NodeslpAddress
1.3.6.1.2.1.999.1.3.1TableslpAddressTablenot-accessiblecurrentA table containing SLP (Service Location Protocol) objects for remote DA/SA address lists known to this managed system. Usage: This table sparsely augments the…
1.3.6.1.2.1.999.1.3.1.1RowslpAddressEntrynot-accessiblecurrentAn entry containing SLP (Service Location Protocol) objects for one remote DA or SA address known to this managed system.
1.3.6.1.2.1.999.1.3.1.1.1ColumnslpAddressIndexnot-accessiblecurrentOrdinal of this conceptual single row in 'slpAddressTable', subordinate to 'slpAgentIndex'.
1.3.6.1.2.1.999.1.3.1.1.2ColumnslpAddressAgentTyperead-onlycurrentThe type of this remote SLP agent (DA or SA). See: 'net.slp.isDA' in SLP API (RFC 2614).
1.3.6.1.2.1.999.1.3.1.1.3ColumnslpAddressSourceread-onlycurrentThe source (DHCP, etc) of this remote SLP agent address. For example 'static(1)'. See: 'slpScopeSource' above in this SLP MIB.
1.3.6.1.2.1.999.1.3.1.1.4ColumnslpAddressOrNameread-onlycurrentText formatted (dotted decimal) IPv4 address; or (per RFC 2373) text formatted (colon-delimited hexadecimal) IPv6 address; or a fully qualifed DNS name for thi…
1.3.6.1.2.1.999.1.4NodeslpAttribute
1.3.6.1.2.1.999.1.4.1TableslpAttributeTablenot-accessiblecurrentA table containing SLP (Service Location Protocol) objects for SLP agent (DA or SA) attribute lists on this managed system. Usage: This table sparsely augments…
1.3.6.1.2.1.999.1.4.1.1RowslpAttributeEntrynot-accessiblecurrentAn entry containing SLP (Service Location Protocol) objects for one SLP agent (DA or SA) attribute on this managed system. See: 'net.slp.DAAttributes' in SLP A…
1.3.6.1.2.1.999.1.4.1.1.1ColumnslpAttributeIndexnot-accessiblecurrentOrdinal of this conceptual single row in 'slpAttributeTable', subordinate to 'slpAgentIndex'.
1.3.6.1.2.1.999.1.4.1.1.2ColumnslpAttributeNameread-onlycurrentThe name of this SLP attribute. For example 'printer-resolution-supported' in the 'service:printer' IANA registered service template. See: Section 5 'Service A…
1.3.6.1.2.1.999.1.4.1.1.3ColumnslpAttributeTyperead-onlycurrentThe type of this SLP attribute. For example 'attrBoolean' for a string formatted boolean. See: Section 5 'Service Attributes' in SLPv2 (RFC 2608).
1.3.6.1.2.1.999.1.4.1.1.4ColumnslpAttributeValueread-onlycurrentThe value of this SLP attribute: a) A UTF-8 string if 'slpAttributeType' is 'attrBoolean', 'attrInteger', or 'attrString' b) an escaped string if 'slpAttribute…
1.3.6.1.2.1.999.2NodeslpMIBConformance
1.3.6.1.2.1.999.2.1ComplianceslpMIBCompliancecurrentThe compliance statements for SNMP Command Responders that implement the Service Location Protocol MIB.
1.3.6.1.2.1.999.2.2NodeslpMIBObjectGroups
1.3.6.1.2.1.999.2.2.1GroupslpAgentGroupcurrentThe Agent object group in the SLP MIB
1.3.6.1.2.1.999.2.2.2GroupslpScopeGroupcurrentThe Scope object group in the SLP MIB
1.3.6.1.2.1.999.2.2.3GroupslpAddressGroupcurrentThe Address object group in the SLP MIB
1.3.6.1.2.1.999.2.2.4GroupslpAttributeGroupcurrentThe Attribute object group in the SLP MIB
Type Definitions
NameSyntaxStatusDescription
SlpAgentTypeTCINTEGER { da(1), sa(2), ua(3) }currentThe type of this SLP agent. See: 'net.slp.isDA' in SLP API (RFC 2614).
SlpAttributeTypeTCINTEGER { attrBoolean(1), attrInteger(2), attrString(3), attrOpaque(4), attrKeyword(5) }currentThe type of this SLP attribute. See: Section 5 'Service Attributes' in SLPv2 (RFC 2608).
SlpScopeSourceTCINTEGER { static(1), staticDA(2), dhcp(3), dhcpDA(4), dynamicDA(5), dynamicSA(6), default(7) }currentThe source (DHCP, etc) of this SLP scope or scope list. See: Section 2 'Introduction' in RFC 2610.