ZXR10-EFM-MIB
45 objects
The MIB module to describe the 802.3ah Ethernet OAM protocol.
Imported Objects
| RFC-1215 | TRAP-TYPE |
| RFC1155-SMI | -- Counter -- mgmt Counter Gauge -- IpAddress NetworkAddress TimeTicks |
| RFC1213-MIB | -- IpAddress DisplayString ifIndex mib-2 |
| SNMPv2-SMI | enterprises MODULE-IDENTITY OBJECT-TYPE Unsigned32 |
| SNMPv2-TC | -- RowStatus TEXTUAL-CONVENTION TruthValue |
| ZXR10-SMI | zxr10 |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.4.1.3902.3.902 | Identityzxr10ethernetOam | The MIB module to describe the 802.3ah Ethernet OAM protocol. | ||
| 1.3.6.1.4.1.3902.3.902.1 | Nodezxr10ethernetOamGlobalObjects | |||
| 1.3.6.1.4.1.3902.3.902.1.1 | Nodezxr10ethernetOamGlobalCfgObjects | |||
| 1.3.6.1.4.1.3902.3.902.1.1.1 | Scalarzxr10ethernetOamGlobalEnable | read-write | current | Configure Ethernet OAM enable(0-disable, 1-enable). |
| 1.3.6.1.4.1.3902.3.902.1.1.2 | Scalarzxr10ethernetOamOuiInformation | read-write | current | Configure Ethernet OAM OUI information. |
| 1.3.6.1.4.1.3902.3.902.1.1.3 | Scalarzxr10ethernetOamRemoteLoopbackTimeout | read-write | current | Configure Ethernet OAM remote loopback time-out. |
| 1.3.6.1.4.1.3902.3.902.2 | Tablezxr10ethernetOamIfConfigTable | not-accessible | current | Configure Ethernet OAM interface parameters. |
| 1.3.6.1.4.1.3902.3.902.2.1 | Rowzxr10ethernetOamIfConfigEntry | not-accessible | current | Configure Ethernet OAM interface config parameters. |
| 1.3.6.1.4.1.3902.3.902.2.1.1 | Columnzxr10ethernetOamifName | read-only | current | Show interface name. |
| 1.3.6.1.4.1.3902.3.902.2.1.2 | Columnzxr10ethernetOamIfEnable | read-write | current | Configure interface Ethernet OAM enable(0-disable, 1-enable). |
| 1.3.6.1.4.1.3902.3.902.2.1.3 | Columnzxr10ethernetOamRemoteLoopbackEnable | read-write | current | Configure Ethernet OAM remote loopback start/stop(0-stop, 1-start). As an interactive operation, zxr10ethernetOamRemoteLoopbackEnable will always be zero(0) be… |
| 1.3.6.1.4.1.3902.3.902.2.1.4 | Columnzxr10ethernetOamifmode | read-write | current | Configure Ethernet OAM mode(0-passive mode, 1-active mode). |
| 1.3.6.1.4.1.3902.3.902.2.1.5 | Columnzxr10ethernetOamiftimeout | read-write | current | Configure Ethernet OAM link timeout value, in seconds, to indicate that during this time, if no OAMPDUs can be received, the link will be lost. It is available… |
| 1.3.6.1.4.1.3902.3.902.2.1.6 | Columnzxr10ethernetOamifLinkMonitorEnable | read-write | current | Configure Ethernet OAM link monitor enable(0-disable, 1-enable). |
| 1.3.6.1.4.1.3902.3.902.2.1.7 | Columnzxr10ethernetOamifLinkMonitorSymbolPeriodthreshold | read-write | current | Configure Ethernet OAM link monitor Symbol Period threshold. Each project has different range and default value of zxr10ethernetOamifLinkMonitorSymbolPeriodthr… |
| 1.3.6.1.4.1.3902.3.902.2.1.8 | Columnzxr10ethernetOamifLinkMonitorSymbolPeriodwindow | read-write | current | Configure Ethernet OAM link monitor Symbol Period window. Each project has different range, units and default value of zxr10ethernetOamifLinkMonitorSymbolPerio… |
| 1.3.6.1.4.1.3902.3.902.2.1.9 | Columnzxr10ethernetOamifLinkMonitorFramethreshold | read-write | current | Configure Ethernet OAM link monitor Frame threshold. Each project has different range and default value of zxr10ethernetOamifLinkMonitorFramethreshold. |
| 1.3.6.1.4.1.3902.3.902.2.1.10 | Columnzxr10ethernetOamifLinkMonitorFramewindow | read-write | current | Configure Ethernet OAM link monitor Frame window. Each project has different range and default value of zxr10ethernetOamifLinkMonitorFramewindow. |
| 1.3.6.1.4.1.3902.3.902.2.1.11 | Columnzxr10ethernetOamifLinkMonitorFramePeriodthreshold | read-write | current | Configure Ethernet OAM link monitor Frame Period threshold. Each project has different range and default value of zxr10ethernetOamifLinkMonitorFramePeriodthres… |
| 1.3.6.1.4.1.3902.3.902.2.1.12 | Columnzxr10ethernetOamifLinkMonitorFramePeriodwindow | read-write | current | Configure Ethernet OAM link monitor Frame Period window. Each project has different range, units and default value of zxr10ethernetOamifLinkMonitorFramePeriodw… |
| 1.3.6.1.4.1.3902.3.902.2.1.13 | Columnzxr10ethernetOamifLinkMonitorFrameSecondsthreshold | read-write | current | Configure Ethernet OAM link monitor Frame Seconds threshold. Each project has different range and default value of zxr10ethernetOamifLinkMonitorFrameSecondsthr… |
| 1.3.6.1.4.1.3902.3.902.2.1.14 | Columnzxr10ethernetOamifLinkMonitorFrameSecondswindow | read-write | current | Configure Ethernet OAM link monitor Frame Seconds window. Each project has different range and default value of zxr10ethernetOamifLinkMonitorFrameSecondswindow. |
| 1.3.6.1.4.1.3902.3.902.2.1.15 | Columnzxr10ethernetOamifperiod | read-write | current | Configure Ethernet OAM PDU period. |
| 1.3.6.1.4.1.3902.3.902.2.1.16 | Columnzxr10ethernetOamiffastflag | read-only | current | Ethernet OAM timeout setting mode. The link operates on slow mode and at this mode, hello OAMPDUs transmit in 1 pps rate when zxr10ethernetOamiffastflag is 0. … |
| 1.3.6.1.4.1.3902.3.902.2.1.17 | Columnzxr10ethernetOamifTimeoutFast | read-write | current | Configure Ethernet OAM link timeout value, in milliseconds, to indicate that juring this time, if no OAMPDUs can be received, the link will be lost. It is avai… |
| 1.3.6.1.4.1.3902.3.902.2.1.18 | Columnzxr10ethernetOamifUnidirection | read-write | obsolete | Configure Ethernet OAM unidirection function enable. |
| 1.3.6.1.4.1.3902.3.902.2.1.19 | Columnzxr10ethernetOamifRmtLbMode | read-write | current | Configure Ethernet OAM capability of responding to remote loopback request. |
| 1.3.6.1.4.1.3902.3.902.2.1.20 | Columnzxr10ethernetOamifRmtLbGuard | read-write | current | Configure Ethernet OAM guard mode of disabling remote loopback mode from attack. True means recovering local slave state from LB to FWD forcefully. |
| 1.3.6.1.4.1.3902.3.902.2.1.21 | Columnzxr10ethernetOamifVariRetrieval | read-write | current | Configure Ethernet OAM capability of responding to variable request. |
| 1.3.6.1.4.1.3902.3.902.2.1.22 | Columnzxr10EFMSymPerSetIfDownEnable | read-write | current | Configure the function enable(0-disable, 1-enable) that the event of link monitor Symbol Period notify the interface down. |
| 1.3.6.1.4.1.3902.3.902.2.1.23 | Columnzxr10EFMFrameSetIfDownEnable | read-write | current | Configure the function enable(0-disable, 1-enable) that the event of link monitor frame notify the interface down. |
| 1.3.6.1.4.1.3902.3.902.2.1.24 | Columnzxr10EFMFramePerSetIfDownEnable | read-write | current | Configure the function enable(0-disable, 1-enable) that the event of link monitor frame period notify the interface down. |
| 1.3.6.1.4.1.3902.3.902.2.1.25 | Columnzxr10EFMFrameSecSetIfDownEnable | read-write | current | Configure the function enable(0-disable, 1-enable) that the event of link monitor frame seconds notify the interface down. |
| 1.3.6.1.4.1.3902.3.902.2.1.26 | Columnzxr10EFMSetIfUp | read-write | current | Set the interface status to up because the event of LM notify the interface to down. As an operation, zxr10EFMSetIfUp will always be got one(1) and be set one(… |
| 1.3.6.1.4.1.3902.3.902.3 | Tablezxr10ethernetOamShowTable | not-accessible | current | Show Ethernet OAM config parameters and state. |
| 1.3.6.1.4.1.3902.3.902.3.1 | Rowzxr10ethernetOamShowEntry | not-accessible | current | Show Ethernet OAM interface config parameters and state. |
| 1.3.6.1.4.1.3902.3.902.3.1.1 | Columnzxr10ethernetOamShowDiscovery | read-only | current | Show Ethernet OAM discovery parameters. |
| 1.3.6.1.4.1.3902.3.902.3.1.2 | Columnzxr10ethernetOamShowLinkMonitor | read-only | current | Show Ethernet OAM link monitor parameters. |
| 1.3.6.1.4.1.3902.3.902.3.1.3 | Columnzxr10ethernetOamShowStatistics | read-only | current | Show Ethernet OAM PDU statistics. |
| 1.3.6.1.4.1.3902.3.902.4 | Tablezxr10ethernetOamIfVariableTable | not-accessible | current | Configure Ethernet OAM interface variable retrieval operation and parameters. |
| 1.3.6.1.4.1.3902.3.902.4.1 | Rowzxr10ethernetOamIfVariableEntry | not-accessible | current | Configure Ethernet OAM interface variable retrieval operation and parameters. |
| 1.3.6.1.4.1.3902.3.902.4.1.1 | Columnzxr10ethernetOamifVariLeafID | not-accessible | current | The value of variable leaf id. Supported variable leaf id as follows: value description 236 OAMID 237 OAMAdminState 238 OAMMode 239 OAMRemoteMACaddress 240 OAM… |
| 1.3.6.1.4.1.3902.3.902.4.1.2 | Columnzxr10ethernetOamifVariRequest | read-write | current | Configure interface Ethernet OAM variable request operation. The operation can request MIB attributes, objects and packages, while only MIB attributes can be r… |
| 1.3.6.1.4.1.3902.3.902.4.1.3 | Columnzxr10ethernetOamifVariResponse | read-only | current | Show interface Ethernet OAM variable response value, as value of set zxr10ethernetOamifVariRequest. |
Type Definitions
| Name | Syntax | Status | Description |
|---|---|---|---|
| EFM-StateValue | INTEGER { enable(1), disable(2) } | current | Ethernet OAM state switch. |